Unable to connect to the router at all!

I just received the MT3000 yesterday. Today, I plugged it in, plugged in the Cat5 cable to the LAN port and could not connect to the router setup page (, as per the directions. I enabled wifi on my computer and saw the SSID GL-MT3000-09e and selected it. I prompted for the network security key. I entered the key exactly as shown on the bottom of the AX3000 router label. It displays verifying and connecting, then displays “Can’t connect to this network”.

I’ve tried a repair, no change. I’ve tried a factory reset, no change.

One thing I’m seeing is the blue light in front is not a solid white. It’s blinking blue. That never changes to solid white.

So, I’m staring at a grey brick sitting on my desk. Not a good start to a beta test!!!

Hi, did you try flashing a clean firmware using the debrick method?


I just tried that. I can’t even bring up the Uboot to do this. This router is hosed, straight out of the box!

from my experience, sometimes debrick access fails sometimes (probably my laptop rj45, cable or any other reason), so worth to test several times and try with different configuration

what is the color/pattern of the light after 90s? DHCP server working in router when not in debrick?

I was also unlucky with my testing router :disappointed:

I’ve attempted the debrick 6 times, all with the same result. Cannot bring up the screen at I know it’s not the cat5 cable, as it works fine as soon as I connect to my regular router and access the internet.
The color and pattern are blinking blue light. As for DHCP, I set the IP as static to, as should be set for the debrick via Uboot.

I think I just got a bad router. I’m not sure who to contact directly for this.

remember to turn off any vpn software running on your pc and try again, i made that mistake just yesterday

1 Like

I don’t have VPN software running on this computer.

Update: Ok, I actually did have an instance of WireGuard VPN running on the computer, that I use when I’m out of the country to allow me to connect to this computer. It allows me to use Youtube TV and any other Geo blocked services as if I were still in the USA. Shutting that down (not sure why this would matter, though) allowed me to connect to the router. Thanks for jogging my memory on this, bOcy!