Unable to connect to Verizon

I received the GLX3000 but it does not work on Verizon with APN VZWINTERNET. Upgraded to the latest firmware and also switched between SIM slots provided still same issues

It’s possible the carrier is limiting it.You can check with ocal carrier.

thanks for responding. It is not the carrier. I switched the SIM to different hardwares/modems which are not glinet and it connects to the internet and to the verizon network seamlessly without any intervention. it is very frustrating trying to swap sim slots update firmware and still same issue with glx3000

You might try changing the IMEI of the X3000 to that of the device that you are able to connect to Verizon on. There are instructions on this forum on how to do this. Make sure to write down the current IMEI of the X3000 so you are able to change it back in the future if necessary. I am using a Visible (Verizon MVNO) sim without issue on the 4.0-release50402 firmware with my IMEI changed to that of one of my Pixel phones.

Unable to connect to Verizon on firmware 4.0.0. with the Mudi E750. I even tried changing the IMEI to the one of my Verizon Inseego M3100 modem I was using previously. Also tried MAC cloning. Was working fine without all that on 3.x firmware but now 4.0.0 it just spins.