Unable to get iOS USB tethering to work with Beryl

Hi, I know this was posted in the past a couple times but those threads are quite old and no longer relevant

I’m unable to get iOS USB tethering workig on Beryl. This worked in the past, now it doesn’t.

  • iPhone showed USB connection prompt, accepted it
  • The little “tethering icon” is showing on the iPhone screen
  • gl-inet admin UI shows Tethering as “Connecting” and correctly detects eth2 (iOS)

It’s stuck on “Connecting…” forever with nothing changing. Tried all the trouble shooting like

  • Resetting privacy settings on iOS
  • Enabling USB only mode by turning off wifi and bluetooth
  • Toggling on/off, restarting

It’s still stuck on Connecting… .

Ifconfig for the eth2 interface

eth2      Link encap:Ethernet  HWaddr C6:C1:7D:4D:DD:70  
          inet6 addr: fe80::xxxx:7dff:fe4d:dd70/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:892 errors:0 dropped:891 overruns:0 frame:0
          TX packets:1005 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:391710 (382.5 KiB)  TX bytes:336007 (328.1 KiB)

The interface is getting an IPv6 address, but no IPv4 from the looks of it?

Any ideas before I do a full factory reset of everything?

Firmware is v4.6.0

I believe there’s a compatibility mode switch you need to enable on ios devices to get them to tether properly.

No, this is just for Wi-Fi connections. Via USB there is no compatibility mode.

Resetting network might help: If your iPhone or iPad won't connect to a Wi-Fi network - Apple Support. (See Step 7)

Sadly I can’t reset network settings because that will wipe wifi configurations and passwords which I currently rely on :frowning:

USB tethering works fine on my Mac, just not on the gl-inet router. Anything else I can try?

Interestingly, I’m also often having issues connecting the gl-inet router over wifi to the tethered iOS hotspot, but the router is the only device I own that’s acting up