Unable to open any website when OpenVPN is connected on Mango

I just bought the mango device, and it’s running the latest firmware version 3.215.

I tethered to my tablet via USB for the internet, everything works fine when OpenVPN is not connected.

However, when I connected to OpenVPN using Surfshark, I cannot open any website so the internet is not available at all. I understand the speed would be much slower when using OpenVPN, but I didn’t expect the internet is not usable at all.


On my phone, it says ‘cannot connect to App Store’, also ‘Safari could not open the page because the server stopped responding’. On my computer, I cannot open even Google.

Any ideas why this is happening? Am I the only one having the issue? Thank you.

By the way, why do you have restrictions for new users to upload photos? I tried to include all the screen shots, but was told I could only have 1. This is not helpful at all!

2022-12-31_23-39-43

This is the speed test result before turning on OpenVPN.

As soon as I connect to VPN, internet is not working

Can you check if there is a DNS issue? Try opening https://1.1.1.1 or pinging 8.8.8.8 to see whether either can be reached.

I do not work for and I do not have formal association with GL.iNet.

HI, if use surfshark by OpenVPN app on your phone, does it work?

If you do not use pad tethering, use a normal wifi network, will the openvpn connects?

If this happens only on tethering, seems it is mtu problem or something special with the tethering network.

Thank you for the reply. Without OpenVPN turned on, I can reach cloudflare 1.1.1.1 or ping 8.8.8.8. With OpenVPN turned on, I couldn’t reach 1.1.1.1 or ping 8.8.8.8. The Mango uses whatever default DNS I think. I have never changed DNS settings in Mango

Thank you for your reply. Usually, I use the Surfshark app on my phone, and everything works. I have installed the OpenVPN Connect app on my phone, imported the config file from Surfshark, connected to the VPN service, and everything worked on the phone.

Thank you. I have spent a lot of time troubleshooting the Mango device. I reset the device to factory default settings, connected to wifi (not tether this time), and the same thing happened. OpenVPN/surfshark will connect every time. However the internet is not working when OpenVPN is on, and the internet is working when OpenVPN is off.

The internet kill switch is disabled on Mango, and I didn’t change DNS settings at all, just used default ones either from my ISP or Surfshark.

In the ovpn file, can you add

tun-mtu 1450
mssfix 1410 

Try to lower these numbers to see if helps

Thank you for everyone’s troubleshooting advice. I ran out of options, so I purchased another VPN from Hotspot Shield and was able to connect and browse the internet. I chatted with Surfshark support and now I have another issue with them. I will explain it in a new post.

1 Like