Unable to port forward on GL-AR750s

I have a GL-MIFI connected to a GL-AR750S.
I am running openvpn on the GL-AR750S and am able to connect to the vpn on my laptop but am unable to port forward.
Running vpn and port forwards on the GL-MIFI works perfect but I am hoping to speed up my vpn with the faster processor on the GL-AR750S.
Thanks in advance.

Could you please take a screenshot of the port forward rule?

This is my setup.
GL-MIFI ip address
GL-AR750 ip address
NAS connected to LAN of GL-AR750 ip address
VPN running on GL-AR750.

How do you access those services? With tunnel IP address or Gateway IP address?


I believe it is tunneling.

I wish to access my NAS from outside the network via my VPN.

My VPN provider has open ports so I can access my devices from outside.

If I run the VPN on my GL-MIFI with the port forwarding set up on it everything works perfect.

However the speed is slow.

I am hoping the GL-AR750 will speed things up.


I assume that the OpenVPN tunnel IP on Slate and PC are and respectively. Am I correct?

If I connect the NAS directly to the GL-MIFI and run the vpn on the GL-MIFI and set the ports up for I can access the nas from outside the network. (using filezilla on my remote pc with the vpn ip address and port 8000. No need for vpn to be on the remote laptop)
If I connect the GL-MIFI (with vpn disconnected and port rules disabled) to the GL-AR750 (with vpn running and ports set) and then set the nas to I can not access it outside the network.
Attached is how I have it set up.
I am not sure about the I don’t know where this would be or how to set it up.

Thanks again.

Gave up and returned the router.
I decided to try a GL-X750. Has the CPU speed of the GL-AR750 with the built in LTE modem and it works perfect.
Shame there is not a battery version of the GL-X750. That would be perfect.