Unable To Setup Second Mesh Sub-Node On GL-S1300

I have a GL-S1300 setup as my primary router and main-node. I already have a GL-B1300 setup as a mesh sub-node.

I am trying to add a second mesh sub-node, but am unable to get it to “pair” properly. I have tried the pairing sequence multiple times, and it fails everytime. I have tried a factory reset on the scond node, and still no success. To make sure the problem wasn’t with the main-node, I did a factory reset on the existing sub-node, and was able to get it to join the mesh network again on the first try, so I know I’m doing it properly.

When I try and add the second sub-node, I hold it for 5 seconds until the blink sequence changes, the blink sequence on the main node stops blinking, but the second node I’m trying to add keeps blinking and never appears as a mesh client. When I look at the available networks I still see “GL-B1300-550”, so it looks like it’s not completing the process.

I can join the wifi network “GL-B1300-550” with the GL-S1300 wifi password, but I’m never assigned an IP, and eventually get “dropped”. If I connect my laptop to the second node with a cable, my laptop is assigned the IP and there are no other devices on the network, it doesn’t even show the GL-B1300 I’m plugged into.

Is this a defective unit? Is there a different way I can get the second node to join the existing mesh network?

Any help would be appreciated.

I dont have either router but you sound like you could use a fresh pair of eyes on this. I found a review/write up on one of the routers here

I skimmed it and found that OpenWRT is overlay to Qualcomm Wi-Fi SON (Self Organizing Network) and that there is a paradigm of ‘master’ and ‘slave’ mesh nodes. In his set up he used the b1300 to be the ‘master’ and then preceded to add ‘slave’ or secondary nodes from b1300. I think it may be one of those ephemeral auth session where requires the whole thing is done at one time and requires flash to reset or start over.
My suggestion is to figure out how to negociate use of Qualcomm SON… lulz.
Goodcloud and Astro-Relay from gl-inet are my second suggestion. That does require setting up for that (agents) and will probably still require knowing Qualcomm SON.

What version firmware? There was an issue with mesh with 3.203 so if you’re using that one you might be best to downgrade back…

I see that the SL1300 is similar to BL1300 with a focus on IoT gateway and using BLE and Zigbee. Very cool but I think that you are hitting difficulty because you are trying to connect two gateways. It could be as easy as switching your hierarchy. BL1300 as Prime and SL1300 Second. BL1300 as ‘router’ and SL1300 as ‘gateway’. Semantics aside that could be best option. Following FW evolution to match required function. These things are only as smart as let them be.
If you start leaving a dent in the wall later… pick up cheaper Mangos and use those as repeaters or extenders. The sip power and nearly industructible.

I downgraded to version 3.105 and that fixed the problem, I was able to connect both mesh nodes on the first try.

Excellent. Im glad that you got it to work. =)