Unable to use the GL-ARM300M in a hotel as a repeater

I purchased the GL-ARM300M router specifically to use while I travel, however, I have been unable to connect to the hotel wifi. The hotel has an unsecured network that does not require a password, however it does have a login screen that has to be filled out to gain access to the internet.

I have seen several postings on this, however none seem to have a solution.

My ole router was a TP-Link - TL-WR802N that performed this function flawlessly. Once logged in, the hotel screen would come up.

How do I configure the GL-ARM300M router to allow the hotel splash screen to come up?
(step-by-step please, I am not fluent in Unix)

if you have used your laptop / phone to connect to the hotel wifi;
then you should be able to clone that devices’ mac address in the ARM300M

that works for me 90% of the time when I can’t hit captive portal page from the router.

sometimes when I can’t get to the portal page, a reboot of the router while connected to the hotel wifi will usually get the portal page to come up.

Thank you for your response.
I tried both the MAC clone and re-boot, neither approach worked.
I am surprised since this router was specifically touted to be a repeater for hotel wifi. Every hotel I have stayed at in the last few years (over 50), uses the log-in screen.

It works fine for me as a repeater… I have used it in 5 different hotels over the past 2 weeks. There’s a setting on the admin page to allow portal pages to pop up… go to more settings, custom dns server, then disable DNS rebinding attack protection. This will allow the portal redirect at the hotel.


Update - I have tried to use this router at multiple hotel chains (Marriott, Hilton, Holiday Inn, etc.), and was unable to get the router to work consistently.
I followed all the recommendations provided in this post; separately and combined in various forms. On the rare occasion I was able to get it to connect (after logging into the hotel), it would drop the connection within a few moments. To reconnect, I had to go through the entire setup again.
The VPN simply does not work. When I could get it to connect, once I turn on the VPN it crashes again - immediately.
In every case, my TP-Link router worked flawlessly, so I know it was not the hotel, or my computer that is at fault. I switched to this GL-ARM300M router specifically to get the VPN functionality.
Any other suggestions on how to make this work?

just out of curiosity what version of firmware is your AR300M running? I used to struggle with my AR150 In similar situations before I updated to the more recent firmware releases. I’ve been on the pre-release version for my device and it’s been working quite well. Check here >downloads It is quite possible wherever your router shipped from had a model with an older firmware installed. It could be just as easy as updating. I hope this helps.

I had updated the firmware when I first had trouble using the router. At your suggestion, I checked again, and it seems there is another issue. I will upgrade and try once again using this third version.

rp2 - when you have a chance how about screen shots of the screen? Thanks Dan

Jgreg7 - this is interesting. I was never able to get the TL-WR802N to show the captive portal login screen… even tried with TP-Link support on the phone.

will do … will be travelling Sunday-Tuesday so I’ll have an opportunity to connect to hotel portal. I have noticed that, with the latest firmware, I sometimes need to hold the reset button for 3 seconds to get the wifi signal to show up.