Unstable wired network on B1300

I’m using GL-B1300 with OpenWrt 18.06.1 firmware.

Recently when I tried to download for a while (bandwidth is about 100Mbps) when connected to the router with a network cable, I suddenly lost connection to the router — ping showed “Address unreachable”, DHCP got no reply after re-plugging network cable. All wired connections seemed totally dead, including WAN and LAN, but wireless was still good. There was also nothing strange in system logs. And the router was back to normal after rebooting.

Did anyone encounter the same problem?

How often does this happen? Any special configs?

There is no particularly special configuration, except for a 6in4 tunnel (HE Tunnelbroker). It seems it’s easier to trigger the problem if I download through the tunnel, but I’m not really sure, because I cannot stably reproduce the issue now.

EDIT: The problem just happened while I was downloading (over IPv6) and watching YouTube (also over IPv6).

Any suggestions on how to further debug this annoying problem? At least I’d like to be able to collect some logs.

I believe I have encountered the same problem. And it was while I was watching YouTube on my Samsung SmartTV which is connected to the B1300 with an ethernet cable. I have IPv6 enabled which my desktop computer and phone use. I don’t know if my Samsung TV uses IPV6. I am using OpenWRT 18.06.1. I notice when I remove the power cord from the back of the B1300 and plug it back in to reboot the router, that there is a large arc flash. Bigger than I have ever seen for a 12vdc consumer device before…

This problem is pretty repeatable for me.

Do you mean unplug the power adapter from your power plug or unplug the power cable from B1300?

If it is the former there may be a flash. But if it is the later there should have no such flash.

when this problem happens, can you pls get the log using

As I said before I’m not able to get any logs. logread and dmesg all look very normal - I even tried to do logread -f while triggering the problem, and there was nothing. Are there any other debugging techniques I can use?

Perhaps not what you want to hear, but since you are on openwrt anyway, have you tried running trunk instead of 18.06?