Update firmware without luci

Hi,

I have a GL-AR300M, currently in /etc/glversion is 3.024.

My problem is that I have installed some package via opkg and now there is a new version of libopenssl installed that lighthttpd (and some other software such as mpd) is not compatible with (and I also cannot update lighthttpd as opkg says it’s up to date).

I cannot find a way to downgrade libopenssl and so I thought the easiest way out would be to install new firmware - however with lighthttpd I have also lost luci.

So could someone please explain to me how to upgrade the firmware without luci?

Many thanks!

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

I really would appreciate if gl-inet would either clearly state that they cannot be bothered to support older devices or else provide proper support… I am a bit fed up now.

The procedure as outlined above does not work.

Firstly which image am I supposed to use? In the doc it says for my device I should download an *img file but in the v1-folder for my device there are only *bin files…

So to be on the safe side I downloaded both openwrt-ar300m16-3.105.bin from the v1-directory and openwrt-ar300m-ubi-3.105.img from the nand/v1 directory.

The next problem is that there are not two options in the uboot-dialog (one for nand and one for nor) but only one.

So I tried the *img-file. That resulted in “update failed”. I complained about the image file being either to large or too small or of the wrong format (or something like that).

So I tried the *bin-fille as well. Here I got “update in progess” but when I restarted my device after about 15 minutes nothing had changed.

I am hoping for some support from the community here as I am 100% sure that I will not get any more responses from gl-inet…

hope you get the help that you need since the weekend is over. this is from the readme in ar300m folder.

AR300M has two flashes, Nor and Nand.

So there are two firmwares, one for Nor and one for Nand.

Nand firmware is in “nand” folder. Normally what you use is in this folder.

All other folders is for Nor firmware. For example, “v1” is our stock firmware for Nor flash and “tor” is the tor firmware for Nor flash.

Note: Old nand firmware may not work on the newest AR300M because we used a different nand chip which is not supported in firmware v2.25 (and clean firmware v1.0) and older.

Update through web Admin Panel: xxx.tar
Update through Uboot: xxx.img
What is Uboot: Debrick via Uboot - GL.iNet Docs

WARNNING: If your device comes with firmware v2.261, don’t use old firmware, because old firmware don’t support the new Nand chip in recent product batch.

1 Like

So what is the “web Admin Panel” for you? Is that luci for you?

What I have tried is the uboot web-ui.
In that I have one button to select an image file and another to start the update.

I have tried all *img files from the nand/v1 directory.

Some (e.g. openwrt-ar300m-ubi-3.105.img) do not work at all. I get an “Update failed” immediately.

Others (e.g, openwrt-ar300m-ubi-3.024.img) sometimes work a little bit so to speak):

What happens is that the update prcess seems to start but there is no indication of any process and it seems that no matter how long you wait the device does not restart (as it is supposed to do).

When I then restart the device sometimes nothing has changed at all. Sometimes something has changed - the WLAN SSSID has reverted to the defaullt and the password has reverted to the default. luci (that does not work in my configuration) runs again and I can log in.

But as soon as I restart the device again everything is reverted back to where I started. Absolutely everything is back to square one.

I have now tried to do a factory-reset via the “30-30-30 method” but again this does not work - it again changes nothing.

I don’t understand what is going on here but my router is in a state where some things don’t work anymore due to an inconsistent state of installed packages and there does not seem to be any way for me to install another firmware. And (as I’ve become used to): No support from GL-Inet.

There is never a 30-30-30 method in GL.inet devices. You should use the uboot failafe guide as given in the guide.

Only one box to upload firmware is fine. You can just try the .img file from https://dl.gl-inet.com/firmware/snapshots/3.201_beta4/ar300m/