Update NextDNS CLI to version 1.43.0

On my GL-MT2500, running latest firmware, the NextDNS CLI version is several years old at 1.37.11-1. The current version is 1.43.0.

I’ve tried updating it using the command line, following the directions at: OpenWRT · nextdns/nextdns Wiki · GitHub

The update says it works, but when I look at the software/plugin list on the router, it shows the version is still 1.37.11-1. If I run the command line updater again, it shows it’s updating to 1.43, but the update doesn’t stick.

Someone had a similar request (Update NextDNS CLI - #6 by Blobbie01) and so I tried downloading the linked v. 1.42 .ipk and uploading it to the router using the GUI. It says the upload was successful, but again, the list shows the installed version is 1.37.

I’ve tread uninstalling several time suing the GUI as well as the command line (opkg remove nextdns --force-remove) and reinstalling and although it says it’s installing 1.43, it always then says the current version is 1.37.

Any help would be appreciated.

Pretty sure the software-list won’t get updated by the updater, so you need to check directly what version is installed by calling the binary. `

nextdns help

Maybe nextdns version is a valid command as well.

Could be helpful here.

nextdns version returns 1.37.11

Completely removing nextDNS & installing the IPK through luci worked for me. I no longer use the gui, but instead the terminal to set it up.

After removing NextDNS, when I install the IPK, I get this error:

Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for nextdns found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package nextdns.

So, looking at the installer, although I’m installing v. 1.43, it’s only downloading v. 1.37 from Gli packages. How do I change this?


INFO: OS: openwrt


INFO: GOOS: linux

INFO: NEXTDNS_BIN: /usr/sbin/nextdns


i) Install NextDNS

e) Exit

Choice (default=i): I

INFO: Installing NextDNS…

Downloading https://fw.gl-inet.com/releases/v21.02.3/kmod-4.2.1/aarch64_cortex-a53/mediatek/mt7981/Packages.gz

Updated list of available packages in /var/opkg-lists/glinet_kmod

Downloading https://fw.gl-inet.com/releases/v21.02.3/packages-4.0/aarch64_cortex-a53/glinet/Packages.gz

Updated list of available packages in /var/opkg-lists/glinet_gli_pub

Downloading https://fw.gl-inet.com/releases/v21.02.3/packages-4.0/aarch64_cortex-a53/packages/Packages.gz

Updated list of available packages in /var/opkg-lists/glinet_gli_packages

Updating database.

Database update completed.

Installing nextdns (1.37.11-1) to root…

Unfortunately, the newest version of NextDNS is not available in the repo.
So far, no way to install it - if you don’t want to go the fully manual procedure - which is a game of luck to get it working.

The “install” script of NextDNS isn’t more than just a bad joke. They don’t download the newest version from their servers - but from the built-in repo in OpenWrt… that’s totally stupid.

Is it an OpenWRT repo or a Glinet repo?

Both don’t have the newest one - since the used OpenWrt version is an older fork.

1 Like