Upgrade from 3.024 to openwrt-ar300m-3.100-1218 fails

I used the .IMG file as directed. GUI indicated success followed by new screen indicating connection lost.

Now I cannot connect via as the device SSID is not visible.
Tried connecting to WAN port with no success.
Tried the unbrick procedure and will not connect.

Any hope?

Where does your .img file come from?
GUI cannot upgrade .img
You can refer to this link to re-update your firmware。


The image file came from glinet in the testing section - as suggested by the new mobile app. I tried the unbrick directions several times as noted. The GUI did display messages indicating it was upgrading via img file. It did reject the tar file as incorrect format.

I guess no one has tried to upgrade the AR300M to support the new GL.iNet phone app described on the companies web site. The Updated GL.iNet App Is Ready! - GL.iNet.

I am returning the box and willing to check for a month or so to see if an ‘official’ release for this support ever comes out. Or until I find another solution.

One side of the company says sure, download the testing firmware to support our app and the other side of the company says what?

Good luck everyone

I tried to upgrade img directly in the system GUI, the system prompted me to check failed.

So, you’re upgrading the firmware in uboot, right?
Prior to this, we found a bug in the AR300M UBOOT, you can try to unzip and upgrade the attached UBOOT.
AR300M fault solution.zip (426.5 KB)