Upgrading to OpenWRT18.06.1 on B1300


#1

I have tried to upgrade to OpenWRT 18.06.1 on my B1300 using the Uboot webUI method with both the snapshot (https://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/openwrt-ipq40xx-glinet_gl-b1300-squashfs-sysupgrade.bin) and released (https://downloads.openwrt.org/releases/18.06.1/targets/ipq40xx/generic/openwrt-18.06.1-ipq40xx-glinet_gl-b1300-squashfs-sysupgrade.bin) versions. Neither seem to work. The upgrade appears to finish but the wifi light never turns on and the unit cannot be accessed via 192.168.8.1.

I can return it to the stock firmware easily and everything works as expected so I don’t think it is the Uboot web.? Or maybe it is? Is there another firmware version I should use? Does the tftp process work better? I haven’t tried it yet.


#2

In their GL-DDNS post they mentioned they should have a v3 firmware ready end of the month, that should be on Openwrt 18


#3

The firmware should work but generally the wifi is not turned on for openers vanilla firmware.

The IP is 192.168.1.1, not 192.168.8.1

It even don’t have Luci installed and you need to ssh to the router to install everything.


#4

I hope that to be true. I wanted to keep the router as stock as possible. Version 15 of openwrt is really buggy in V2. For example, I could create another AP called it Guest but could not isolate it from my network. I followed the OpenWRT guide they had pictures for V18 not V15.


#5

I used the TFTP method to flash stock OpenWrt, this video explains how to do it:

However I did it using a Debian laptop rather than a OSX machine, install and setup the TFTP server:

apt install tftpd-hpa
wget https://downloads.openwrt.org/releases/18.06.1/targets/ipq40xx/generic/openwrt-18.06.1-ipq40xx-glinet_gl-b1300-squashfs-sysupgrade.bin -O /srv/tftp/lede-gl-b1300.bin

Set the IP address of the Ethernet port on your machine to 192.168.1.2 and power cycle the router (I plugged the Ethernet cable into the middle port).

Having a USB 2.0 To TTL UART 6PIN Module makes things easier as you can see what is going on.

The default firmware does come with Luci, there are also quite a lot of updates available for it which I installed like this:

opkg update && opkg upgrade $(opkg list-upgradable | awk '{ print $1 }' | xargs)