Urgent - how to completely reset a DL-X750 to shipped config

Just got a DL-X750, put in my 4G SIM (Optus, Australia), and it auto-configured worked fine.

Then, I decided to measure performance on each band, and used the preset “Set Band” AT command to set band 1.

That broke network access and I haven’t been able to get it back.

I have done every type of reset imaginable, I used “Set Band” again to try to set a known good band (eg. 28) (which didn’t actually change anything), I’ve tried flashing older firmware and Rooter, I’ve been through the Quectel AT command spec and tried anything that looks relevant (AT+QCFG=“nwscanmode”, “band”, etc), I’ve left it powered off overnight, I’ve checked the SIM still works on another router, and so on. I’e done everything but sacrifice a chicken.

But nothing fixes it. I can’t get it to connect to the network, and the preset “Request network information” AT command only ever returns:

+QNWINFO: “WCDMA”,“50502”,“WCDMA 900”,3046

Can anyone please tell me how to completely and utterly reset this device so that it works exactly as it did when I took it out of the box 24 hours ago? I’m going mad.

There should be a AT command to set the band to original. Will find it.

Thanks in advance. I spent ages reading the AT command spec last night but found nothing appropriate.

The default band Settings are shown

for example with EP06-E


Thanks but that doesn’t seem to have helped. The command worked, and I now get:

+QCFG: “nwscanmode”,0


+QCFG: “band”,0xffff,0x7e00000000000000000000000000000000000000000000ff000001a0880800d5,0x0


Still can’t connect.

Probably not the brightest move, hehe, live and learn, eh?

The SIM card is going to provide the best service based on local RF conditions and the billing plan associated with your account - the SIM does recognize the capability of the modem/handset it’s inserted into.

Getting back to normal…

Honestly - this goes back to old-school modem days - try ATZ - seriously, some modems will reset this way.

Otherwise - see commands below, as the AT+C functions are 3GPP standard, so should work across all modem vendors.


These 2 parameters fun and rst are defined as follows:

0 Set as minimum functionality mode (set the RF off but keep the SIM power on, previous mode must not be offline)
1 Set as online mode (default value) (previous mode must not be offline)
4 Set as offline mode (previous mode must not be FTM)
5 Set as offline FTM (previous mode must be online)
6 Reset MS (previous mode must be offline)
7 Set as RFoff mode (about radio frequency)

rst: Whether to restart MS before setting
0 Not restart MS before setting. (Default)
1 Restart MS before setting. (fun must be 1)

Enjoy and good luck!

Thanks, but if it’s there in the main user interface (band lock command), I wouldn’t expect using it to completely and irrevocably (it seems) bugger everything up! :wink:

Sometimes you have to do this stuff, because things don’t work as they’re supposed to. Ask a Netgear AC800S owner - that has a habit of randomly resetting unless you disable LTE band 3.

Anyway back on topic…

I definitely wouldn’t know what I was doing if I used that command.
What are “FTM”, “MS”, “RFoff”?

Try the command to restore factory Settings


Brilliant - that worked!! Back on the network again, happily aggregated on B3 + B28.

Thank you so much!

Might I suggest that that command is documented somewhere prominent, eg. in a FAQ? Or better yet, put in the drop down list of canned AT commands. It isn’t in the Quectel AT command reference.

Now that I know how to get out of it, I’m wondering whether I dare set the band to 1 again and see if the whole saga repeats. There’s clearly something very wrong going on when I do that. Might help find a bug.

1 Like