USB acts different between routers

I think he wanted one of the USB devices, not the router?

I tried a USB device using cp210x chipset and Mango can see it.

I also tried other two USB devices which usb serial chipset and the USB can also detect.

Maybe you can send me one device and after troubleshooting I can send you back.

You were right bring.fringe18.

I purchased another powered hub of better quality and now the mango can see the usb device. However, the problem is the mango because I’m providing it power from a PoE connection so that it can draw what ever it needs but it’s not doing it.

1 Like

That reads as if you’ve discovered a bug to kick over/up to GL to straighten out.

(I look forward to you marking my post ‘solved.’ What can I say? I’m a little egotistical. :wink: Have a good one.)

Well, it was the answer but it’s not actually the solution :).
There is a problem with the USB port of this device and I don’t know what the solution will end up being as I cannot add powered hubs to every Mango router.

1 Like

Perhaps not but now it’s on GL to investigate further why their device isn’t pushing a full 500mA. Maybe there’s something needing to be tweaked in the custom build of OpenWrt they’re working with.

It may be this reason or may be not.

Even there is not enough power there will be log in kernel showing some error -71 etc.

I was asking when I started the post, how can I diagnose this then?
Is there a way to log this information?

For this diagnosis you need some measuring/testing equipment.
A USB 2.0 has to be able to deliver a voltage between 4.75V and 5.25V with a current of 0.5A (former 0.1A). The first thing I would do, is to connect a load (10 Ohm, 5W) and measure the voltage. It should be clearly above 4.75V.
The second measurement is the current consumption of the device, this is not as easy as it seems. You can measure the current using a device as shown above but this don’t tell you anything about peak-currents occurring e.g. during plug-in or switch-on. You have to do these measurements using an oscilloscope to determine the peak-currents and see, if they exeed the specification of USB2.0.
Additionally you have to measure the voltage with an oscilloscope to show, that it stays within the specification all the time.
To find a solution, you first have to know what the problem is.

1 Like

… or you could just grab the spec sheet & hope the manufacturer’s not lying. YMMV.

1 Like

That’s way too much work for something that should simply function.

The fact that I can get the device and even a second one working using the USB port when using a powered hub seems to tell me everything I need to know. The mango doesn’t seem to have the same power output that the ar300 does.

It would take a month for me to send one of the devices to China then have it sent back. Surely, there is some simpler way to test. I do have one of those USB testing devices. Even if it’s not 100% accurate, it should give some idea of what’s going on.

So that’s it, no other ideas other than having to send a USB device all the way to China and back?

It seems like. I don’t like it when I stumble upon an edge case either. Does any of this happen to relate to your employment? Having the bossman write it off as a business expense might help take the edge off.