USB acts different between routers

I’ve asked about this before but never got any useful help.
On the GL-AR300M16, it can see a certain USB device.
On the mango, it cannot see the device.
I thought it might be an openwrt problem but it seems to be something with the routers.

How can I diagnose what the problem is?

Can you install usbutils :slight_smile: ?

And then use ssh and type in the cli lsusb and show the result :+1:?

if you need help using ssh let me know.

Yesterday with the mango i experienced something similar but for a different use a printer port via usb, then i figured the usb was not fully inserted it felt a bit sturdy but it should go full in.

lsusb can help with this, since it shows if the linux system sees it atleast.:+1:, maybe for the usb device in general you need a kmod, what type of usb device is it?

What devices?
You can check the log when you insatall the USB devices?

You can find the log from the UI if you using firmware 4.x

1 Like


This has been a problem for years. I’ve asked about it here and in openwrt forums before.
The devices are currently running openwrt 22.03.3. I only use command line, I do not use GUI.

The problem has something to do with tty to USB between the routers.

The ar300 sees the device and can use it.

$ lsusb
Bus 001 Device 002: ID 0590:00d4 OMRON temp sensor
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.161 ehci_hcd EHCI Host Controller

The first device is the one I’m trying to get to work on the mango.

The FTDI package and others must be installed for this device to work.
These packages installed on both as the usb sensor needs them;
kmod-usb-serial kmod-usb-serial-ftdi kmod-usb-uhci
I do have usbutils installed.

I also have to run the following commands;
modprobe ftdi_sio # One time
echo 0590 00d4 > /sys/bus/usb-serial/drivers/ftdi_sio/new_id

After doing this, both the ar and the mt300 show the correct result;
$ cat /sys/bus/usb-serial/drivers/ftdi_sio/new_id
0590 00d4

However and this is where the problem lies, when I connect the device to the ar, the correct ttyUSB0 shows up in /dev but it never shows up on the mt.
crw-rw---- 1 root dialout 188, 0 Jan 10 16:06 ttyUSB0

On the mt300, plugging in before powering up, or after power up or rebooting, it never sees it.

In logread, this is all I see, no temp sensor.
usbcore: registered new interface driver ftdi_sio
[ 17.442745] usbserial: USB Serial support registered for FTDI USB Serial Device

$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.161 ehci_hcd EHCI Host Controller

$ lsusb -d 0590:00d4 -v
Gives nothing what so ever.

Nothing in the logread either, nor dmesg.

hmm this is my output:

root@printserver:~# lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux 5.10.176 ohci_hcd Generic Platform OHCI controller
Bus 001 Device 003: ID 03f0:0f54 HP OfficeJet 6950
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.176 ehci_hcd EHCI Host Controller

the two ohci and ehci controllers are on my MangoV2, I see one missing on yours?

I’m using firmware 4.3.7 release4 (compile date: 2023-09-13 16:05:43(UTC+08:00)

On which device are you running your lsusb command?
And, as shown in the output, on the ar, it works fine, even if it seems to be missing what you have but on the mt, nothing what so ever.

It’s on the MT300Nv2 :slight_smile:

Ok well, your mango is configured differently than mine :).
I have nothing else configured to use usb other than this one sensor that cannot be seen.

Does hotplug the USB dongle make any difference?

I’ve tried all combinations. Plugged in before power up, plugged in after power up.
Removed and plugged back in after power up.
Left in and simply rebooted.
Used usbreset with the product code xxxx:xxxx and what ever else I could think of.

Nothing ever works.

The problem is that because of this, I have to maintain software for both the mango and the ar300 which can get costly. I can only use the ar300 when I need to use certain sensors because the mt300 won’t see them.

Does hotplug the USB dongle make any difference?

I’m not sure what that means. If you mean pulling the device out then plugging it back in, yes, I’ve done that too.

Do you think you can send me such a device for troubleshooting?

It’s all of the mt300n v2. I have over 80 of them, not one of them recognizes this device while the ar300’s all do.

I mean “this device”.

Sorry, I meant to come back all day to edit that but kept getting busy.
The devices are over $100 each so I’m not sure I want to ship one to China I assume.
However, I could give you remote access to a v2 with the device connected if that would help?

So other than what I’ve done, what else could I try to find out what is causing this?
I would prefer using just one model if possible.

Can you check the results of the power draw via a DMM or similar device? I suspect the Mango may not be pushing a full 5V/500mA.

Perhaps a powered USB hub could be put in place.


Using a similar meter as yours;
Without the USB stick connected, I see 5.18V, 0.17Amps.
With it connected, it’s 5.17v at 0.19Amps

I’m not sure that’s the problem since the device isn’t even being seen. You’d think it would be seen or there would be something in the log, even if just for a few seconds.

I tried a powered hub and no difference.

(I should point out I just pulled that image fr a search. I don’t have one… so I’m pretty useless here re: logs.)

NP, but still have no leads on why this is happening. Would be nice if a gl.inet person could offer some thoughts on testing.

Well, @alzhao is the CTO; I think he’s interested in getting the router in his hands but I don’t want to put words in his mouth.