USB-C hub on Brume (GL-MV1000)

Hi. Since the USB-C port on the Brume (GL-MV1000) is a power and data port, I was wondering if it’s possible to use a PD USB-C hub to provide the Brume with power and to connect a wifi dongle and tether a smartphone at the same time.


I think so. As long as the power adapter can provide 5V3A.

Pls note, using PD power adapter for the router is not optimal. This is because, a PD power adapter generally have multiple output socket. When one socket has new device plugging in or unplugging, the PD power adapter may regoniciate the voltage on all socket so it cut output, causing the router reboot.

1 Like

Thank you. I bought the following USB-C hub and it doesn’t work:
It was cheap and probably won’t ever work.

That said, I also tried plugging in a few powered USB hubs to the USB port and none of them allow my RTL wifi dongle to be seen by the Brume. The dongle works when connected directly to the Brume though.

Is there a plug-in I may need to install? If not, I either have 3 really bad powered USB hubs (and a few non powered) or the dongle is faulty when used with a hub. It’s very peculiar.

Thanks for the help!

I see. These typeC hubs are not PD actually, i.e. it only tansfer data but cannot distribute enough power.

I think it can even hardly to charge a phone.

The USB-C hub states that it has PD passthrough and there are reviews that confirm it is works for at least 40Wm (5V8A). The router would not have been able to boot if the hub does not supply enough power.

I have this “no so cheap” USB-C hub that works perfectly to power my HP laptop and adds ethernet port/sd card reader/USB 3.0 ports/HDMI ports:

It powers my GL-MV1000W, but the USB ports are not recognized. GL.Inet should confirm that the USB-C power port is actually connected to the USB chip and not be for power-only.

This is pretty much exactly my experience. It passes through power but the USB ports aren’t recognized.
My problem is that even the USB-A port doesn’t recognize anything connected to a hub on it either. So weird.

I plugged in a TP-Link UE330 USB 3.0 non-powered hub/ethernet adapter into the USB 2.0 Tyoe A port on my GL-MV1000W. The router was able to recognize, mount and share a USB flash drive.

I can confirm that the USB-C power port is not for power only. In SSH, the lsusb command shows a USB 3.0 5000M root hub.

Also, @dragon788 states in the thread:

"The most awesome and unexpected feature of the BrumeW has been the USB-C port also appears as an Ethernet connection if you happen to have it plugged into a computer or other device capable of supplying enough power for the router to operate. I wasn’t expecting this and it blew my mind because it means that I should be able to far more easily route only certain traffic from my computer over the “wired” connection while still remaining connected to a work or other wireless connection rather than having to flip back and forth between a work connection and a personal/VPN protected connection.

I’ve tested this on both a Macbook Pro and a Chromebook, and on the Chromebook I was actually just using a USB 3.0 port and not a USB-C/PD port. ChromeOS happily recognized the router as an Ethernet connection once the router had fully booted."

I tried this by plugging the plugging the router’s USB-C port into my PC’s USB-C PD port. Windows 10 detected the router as a RNDIS/Ethernet Gadget and I had to manually install a RNDIS driver. I could then access the Internet over “ethernet” through the router.

It still remains unknown why the router’s USB-C port does not work with a powered hub that has other devices.