USB modem works wonder on PC, disconnects with Beryl AX

I own an alcatel linkkey USB modem.

I used to use it on my laptop and it works wonderfully, never had an issue.

I bought a Beryl AX router and used the modem with it to share the connection between more devices.

It gets recognized as Android thetering (this wouldn’t bother me) and works at first but then despite the light on the modem keeps reporting a stable connection, the Beryl complains and starts blinking.

What can I do about this?
I really want to like the Beryl and not to return it but I need it to work as flawlessly with my USB modem as my PC does.

Please advice how to make it work better. Thank you,

The Bery AX can only provide a maximum current of 1A, please check that your device is operating in this range.

It is thanks. I tested it with an usb ampmeter, it draws about 0.5A.

What do you get from lsusb?

lsusb: not found

Apparently I “solved” the issue though. Factory reset and re-configured everything, it’s working now.

I did not do much beforehand. Just experimented with turning on and off adguard and enabling multi-wan (then turning it off again).

Apologies. lsusb isn’t stock. opkg update && opkg install usbutils for the future.

It happened again. It won’t be practical to reset the router daily so if I don’t get over this quickly I would unfortunately need to return it.

I am trying to fetch usbutils but…

Database update completed.
Collected errors:

The odd thing is that my laptop that is connected to that very router (and has no other routes towards internet nor anyone whatsoever) can happily wetch that package with wget, while the router itself cannot.

What firmware are you running? I’m not on OpenWrt v21.02.03 but the previous SNAPSHOT.

I’d reboot & try again. There may be something locked up in the routing or something like that. No issue on firmware 4.2.1-release4:

root@GL-AXT1800:~/backup/package-lists# opkg install usbutils
Installing usbutils (013-2) to root...
Installing libevdev (1.12.0-1) to root...
Installing libudev-zero (1.0.0-1) to root...
Installing usbids (0.354-1) to root...
Configuring libevdev.
Configuring libudev-zero.
Configuring usbids.
Configuring usbutils.
Updating database.
Database update completed.

The peak power drain of the modem can be high. If it breaks when you do speed test it is usually a power issue.

Nope. When the modem has power issues its led changes color while it never does here.

Firmware is 4.2.2.

I installed a vpn client on the router now. With the VPN active I can update the opkg database (!) and install lsusb. Its output is:

root@GL-MT3000:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.211 xhci-hcd xHCI Host Controller
Bus 001 Device 005: ID 1bbb:0195 Alcatel Mobilebroadband

Many thanks,

Have you tried to Google it? Someones has successfully configured it on OpenWRT:


Thanks will look into it.

What is PARADOXICAL is that by using a VPN (wireguard, for what it may matter) I solved everything.

No more losses of connections, no more high latencies, no issues whatsoever.

Except the slight performance degradation of the O

I really want to have it as stable without a vpn though, for several reasons (one being… The cost of the vpn).

How could I debug this?
How can be any connection through the vpn perfectly stable while totally the opposite without it?

Thanks again everyone for your kind help.

This is mere speculation but I wonder if the usually included directive of KeepAlive 25 seconds has something to do w/ that. Activity on the link/tunnel could be enough to keep the USB modem from entering a ‘low/powerdown’ scenario.

I’d be temped to do some packet capturing for some period of time then see what WireShark can give you for an analysis. You’d have to determine the name of the interface you’re targeting (ip a should help). At least you might get an idea of what’s happening to the traffic &/or see if there’s a periodic timeout causing the issue. IDK; again, speculation.

I really want to have it as stable without a vpn though, for several reasons (one being… The cost of the vpn).

Well, worst case scenario: get another VPN provider for ‘day to day’ use… I can tell you personally Surfshark via WG works just fine w/ f/w 4.2.1-r4. They’re dirt cheap (< 2.00USD/mo) if inquire about a long term subscription (sometimes not openly advertised).

1 Like

There’s another issue other than price; most IP addresses are somehow graylisted by a lot of internet services. When I’m connected to the VPN I often have to do captchas to prove “I am not a robot” just to visit a website or do a google query.

Moreover, it just has to work without it LOL :grinning:

I run Surfshark 24x7. I know exactly what you mean.

Do you remember some decades ago the prevalence of so-called ‘WinModems’ (aka softmodems) back in the dial-up days? Yeah; I think that’s what you might have going on there if nothing came come of those links SplitzAX3000 posted ITT.

It’s probably ‘infected’ w/ some supposed ‘green’ functionality to power down when there’s no usage. IDK; maybe it’s worth setting up & testing watchcat to do the equivalent of WG’s KeepAlive directive.

1 Like

Thanks, I’ll look into that, although I am not 100 percent convinced that might be the case as if I attach the thing directly to my laptop and I use it just in the very same way I don’t get the same behaviour. Oh, whatever!

Your could have a difference scheme for power saving/USB polling. I have ‘USB selective suspend setting’ in my Win 10 power plan disabled. I do the same for PCI Express → Link State Power Management disabled. YMMV.

(I assume the USB modem is a Link Key IK40 as SpitzAX3000 linked to. That model is advertised as Linux compatible.)

As said ITT, I’m shooting in the dark. I’d first try a WireShark analysis to see if I can get a sense if it’s a regular period or random when it drops while the connection is just idling.

1 Like

Maybe these lines I found in the system logs could be useful.


Mon Jul 3 13:00:19 2023 kern.err kernel: [14074.329123] 7981@C13L1,tx_free_v3_notify_handler() 3526: ContTxFailCntTotal = 4, ContTxFailCnt300ms = 1

There are plenty of those lines in the system log. Being it (apparently) a kernel error I’d have no idea about how to move forward.

Any hints would be much appreciated. Many thanks!

Just a heads up on that aspect: I’ve seen non-impacting ‘warning’ or ‘notice’ log entries recorded as .err entries. Sometimes it’s just a case of how a particular dev set that piece of software/functionality to write/‘tag’ the messages.

If I were in your shoes I’d be trying a tcpdump & WireShark analysis to try to work out if the dropped connection is a periodic-based pattern.