USB tethering as fallover on GL-ax1800 Ver 2.0

Hello, this morning I got a message that my provider is ‘working’ on my landline and I cannot use it till late in the afternoon.
I already asked about USB tethering and I wanted to use that solution so I can use internet, network wide.
But, when I connect my phone to USB, disconnect WAN cable, turn USB tethering on, it works for a few minutes and then it ends.
the router displays: “The interface is connected, but the Internet can’t be accessed.”
I tried using another cable but still the same. I can’t get USB tethering working again.
My router is setup with Adguardhome and VPN server and VPN Client.

Can you help me sto get my local network connected again?

Thank you very much.


You should conduct the testing while all non-default services are turned off.


Thank you for your reply.
I want to use the tethering option as a FAILOVER solution for my configured router.
I do not want to reset my router each time when there’s a disconnection of my ADSL line.

greetings Tom

First of all, clear the system logs.

/etc/init.d/log restart
dmesg -c

Next, repeat the same steps you did before (quoted above) and once your Internet stops working, Export the logs and share it so that others can help you; or you may find out the causes :wink:

Again, thank you.
I’ll test it this week and sent the update.

grt Tom