USB Tethering broken in IOS 14 (Fixed Nov 26 2020)

I updated to iOS 14.1 - no change, still not working.

1 Like

Please keep an eye on the links i posted here:

This issue is in the underlying library that OpenWRT (and GL) firmwares use for tethering.

You guys should probably complain with Apple, as they released a breaking change for many users without any warning so that devs might have a chance to fix it beforehand. As already stated, all brands and hardware seem to be affected, not just OpenWRT based routers.

As Apple have also not released any specs to what has changed, you can see in the links above some generous people are donating their time to reverse engineer the changes and make the fixes.


So Im having the same problem…I wanted to check and see if i could tether my phone directly to my mac-air…as soon as i did i got a request to install a program from apple, after installation everything worked on my mac-air. Just wondering but maybe apple is setting up tethering to only the computers that can communicate with the software on the iphone and since the router doesn’t have this software or maybe its hardware the software is looking for. just a thought…

1 Like

Same USB tethering problem here on my GL. But note that the problem also exists on ANY Linux computer.

Apple has already stated that they won’t provide a fix, and it is up to manufacturers to update their systems. But Apple does not state what to update or how. The problem impacts the ENTIRE Linux ecosystem.

Bottom line is that Apple sucks hard. But hopefully GL or others can come up with a way to implement a fix.

I have no way to check this, but it seems incorrect given that the issue exits in all iterations of Linux (Ubuntu, Pop, Manjaro, Fedora, etc.) and across kernels.

I’m pretty sure all linux versions use that specific library for apple devices.

Looks like there is a patch coming to linux. Solved on the Linux side a few days ago and needs to work through the distro process. .
Hopefully firmware gets updated quickly.

Yes. Actually good progress. Trying the patches


This is great news!!
Hope that this will now be fixed for the GL-Inet routers asap!

@Gl-Inet: any view, comment, timeline on this?

Patches are being tested right now. No ETA at the moment.

1 Like

Dear all, pls test 3.105 snapshot from

IOS 14 tethering is working again.

Pls check updated firmware from time to time

Update: 3.105 has been released on Dec 9 2020 and you can upgrade online.


CRAAAZY!! This really seems to work. Just tested quickly for a minute:

  • AR300M16
  • iPhone 12pro
  • tethering USB
    => working!!!

I will run a longer test to check if the connection will stay stable.



Tethering via wifi still not working, I dont know its work on ios 13-below or not because I bought the mango since my iphone already on ios14 but connected to router is fine. Is this normal ?

Do you mean you cannot scan wifi networks? It was a bug on MT300N-V2 and fixed in 1127 snapshot.

I just tried and it can connect to ios14 hotspot via wifi. I can also browse the Internet fine.

Thanks for reply. Its 1127 or 1126 snapshots? I can’t find 1127 on link above.

Scanning is fine, I can discover my iPhone hotspot. The gui keeps said error time out every time joining and log always read wwan down and disabled. Or maybe its just defect unit

This one

How do you install this patch on a GL travel router?

You install firmware directly.

I installed the firmware upgrade and after a number connections and reconnections and reboots, it works with IOS 14.2 on a GL-300AR and a GL-750. But as soon as disconnect anything it seems to go back to how it was before. In other words, it is not very resilient.