USB Tethering broken in IOS 14 (Fixed Nov 26 2020)

Does this fix work on the GL-AR150?

Please see this post higher up:

After you install the most current patch, check the snapshot folder to see if there has been an update to improve it. There have been 3 releases this past week already. They are still testing and improvements seem to be coming which is great!!

The 11/26 patch on the AR750S worked great. Thanks a lot for getting this fix in!

Used the openwork-ar750-3.105-1127.bin and it now works with the iPhone, guess i will need to sell the test Android device. Great work!

It is so great that you guys got on this quickly and were able to resolve.

That said, I am having similar issues: the patch seems to allow my AR750S to pass through USB tethered internet from an iPhone running iOS 14.2 but it stops working intermittently. Is anyone else having this issue?

Does it matter if we use the .tar or the .img for our specific model?

Also, is it fair to assume that all of the firmware uploads posted after 11.25.2020 in this directory will include the patch?

Lastly, is there a way to confirm that the firmware uploaded and applied? I can’t seem to reconcile the info reported by the GL-AR750S and the info on the download snapshot website. For example, this is what the GL-750S states:

Model GL-AR750S
Architecture Qualcomm Atheros QCA956X ver 1 rev 0
Firmware Version OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.9.120

But the download site for 11.29.2020 says only:

The firmware version in Luci is the base system’s version. The GL firmwares are based on OpenWRT, so that is the version you are seeing there. That version will not change often, once a year or 2 if even that (OpenWRT 19 was not very stable on release, with a lot of random crashes, so extra time has been needed to wait for them to fix issues, and then further testing by GL to get their stuff stable as well, so versions lag behind a lot). 3.200 versions will be based on 19.07.x.

The snapshots version is in the GL UI Upgrade page, it will say the compile date and version number. From that you can see which firmware was actually flashed.

Also keep in mind that the snapshots reflect current GL code, and can introduce bugs at any time. I don’t know if the old testing (more stable) firmwares will be reintroduced, @alzhao must answer that.

I’m using the latest snapshots and I have this working great on my 750slate, but my Brume GL-MV1000 (no wifi) will not tether. Is there an issue here still?

I’ve recently noted that tethering is not working on any iPhone 12 model. They run on a slightly different iOS version (14.2.1) compared to other iPhone models (14.2).

I’ve posted details here.

Seems that iOS 14.2 is not working for tethering.
In my case, iPhone 6s running iOS 14.2 and mango running 3.105 won’t work together as tethering.

I am using IOS 14.3 with Mango 3.105 and it works OK.

I’ve tried usb-tethering and wifi-hotspot in iphone + wifi connection mango to iphone. not working. I wonder why it is working on some devices and some not.
You can’t really set sth different, neither in iOS, nor in mango gui.
Just enable hotspot in iphone, plug in original iphone cable in both devices, and click “connect” in gui at tethering. No special settings.
Do tethering depend on provider? I could use tethering (wifi hotspot) with other devices such as iMac and iPad mini 2 (wifi only).

Did you phone pop up a message to trust this device?
Did the router get a valid IP address from your phone? It has to get IP, even when tethering is broken, IP can be obtianed.

You can also turn off hotspot, wait for 5 seconds, then turn it on again.
Other than that, no idea.

@alzhao: yes, i trusted the device and needed to confirm with the iphone code.
Am not sure if the mango-router got an ip, because it’s feeling that the connection could not be established. During waiting to connect, the router is falling back to wifi-connection like before (before i tried to use tethering over iphone for internet-connection, the router was connected through wifi to my guest-wifi).
It’s also no blue bar visable on iphone, which always appear when devices are using the hotspot.

Similar, though not identical issues using a Spitz (GL-X750C4). Did online upgrade to (presumably retail) 3.105 which gave me this:
Current Version
Compile Time
2020-12-14 17:13:28

Iphone 11 running IOS 14.3 as wifi hotspot works but USB Tethering doesn’t. The iPhone shows up on the Spitz a a tethering device, and the blue hotspot icon appears on the phone, but clicking the “Connect” button on the Spitz gives a connect failed error.

USB Tethering worked fine using an older iPhone 8 running iOS 13.6, but not IOS 14.3 on the iPhone 11. Is there an additional update needed beyond the 2020-12-14 / 3.105 build?


I have just installed iOS 14.3 and can confirm that tethering has now been restored.

It seems 14.2.1 on the iPhone 12 kills the tethering function.

Device: iPhone 12 Pro
iOS version: 14.3
Firmware: openwrt-mt300n-v2-3.105.bin


IPad Pro, iOS 14.3
AR750, Firmware updated to 3.105 release 1129 on 12/1/20

Was working before 14.3 but now it’s not. iPAD dings when cable connected but does not connect (no blue circle).

+20 minutes…
Tried again after rebooting everything and it works now.

1 Like

IOS tethering seems to be a little bit tricky. Need to disconnect and connect again, or turn off hotspot and turn it one again, 1 or 2 times then it works.

The update does not fix USB tethering for my iPad 6th generation using iPadOS 14.3. Fortunately I also have an old iPad mini 3 with IOS 12.4.9 that I can tether from as well as an iPhone 7 with IOS 14.3 that both work perfectly . I have tested on a GL-MV1000 and a GL-MT1300, with the 3.105 and 3.200 firmware versions respectively.

I installed iPadOS 14.4 and now iPad tethering works!