USB Tethering with GL-MT300N-V2

Recently purchased a GL-MT300N-V2, have updated to latest firmware.

Connected via USB to a Galaxy S9 running on Android 10 security version 1 April 2020

On the GUI I get the notification for USB0 to connect, click onto it and nothing happens just spins.

I have tried plugging the phone into laptop directly and USB tethering works perfectly, have tried 3 USB cables from cheap to expensive and even the genuine Samsung cable.

Tried my sim in an old Galaxy S8 and that works fine.

Tried Two Galaxy S9 and a Galaxy S10 all on the same firmware version and none of them work.

Any advice please?

1 Like

I am afraid if this router does not work with galaxy s9 I will need to return it, can anyone from support help please?


Hold on. Seems we found the problem. It should be the same as S10.

We will have a 3.104 firmware for MT300N-V2 solving this issue. Pls hold on a moment.

Thanks, will it be available for auto update or will I need a manual firmware file?

Can you pls try v3.104 from

Same problem, just spins and won’t connect

I am an S9+ user. I have tried 3.102 and 3.104 firmware for MT300N-V2 and they both can internet with tethering normally. However, I cannot change the method of USB directly from the control panel. I need to change it from setting.
Maybe this is the bug of Samsung mobile phone.

Hello, I’m having exactly the same problem with a Samsung Galaxy S9+ on Android 10 !
I even went and bought a cheap usb 2.0 cable to try with it and still nothing … the connect button spins for a moment a nothing happens …
Tried with the last firmware and the testing one too. Issue not fixed.

I just tested the USB tethering on a Samsung S21(5G) with android 11. The tethering works fine with Mango(Firmware V3.105)here is the download link: GL.iNet download center
But I must tell you guys, make sure your USB cable is a cable that can transfer data with samsung smartphone because I tried 3 USB cables, only one can work with android smartphone data transfer, so you can select connection method (charge only, USB tethering etc…) in the notification bar.

1 Like