USB Wifi Antenna with GL-AR300M

Hi Guys,

Sorry for what may seem like a simple request, but this is my first foray into these kind of routers. I’v spent the best part of the last hour or so trying to work this out and searching.

I basically live on a boat and bought a Kuma USB Wifi Antenna to try and get a better Wifi connection. After reading someones review saying that they plugged this antenna into their older GL-M300A and it worked instantly because its a Ralink network card.

So I bought the two but having real issues figuring out how to get it to work.

I’ve got it set up as a repeater at the moment and connected to my desired network, but it appears to be using the internal Wi-Fi. How do I select the radio I want to use?

Thanks in advance.

Bump - I have tried doing loads more searching but it seems pretty niche what I am doing!

When you use GL UI to set up repeater, it will use the internal wifi radio.

You need to use Luci (advanced settings) to set up.

Luci -> network -> wireless

You will see two wifi radios, radio0 and radio1. Generally your new wifi dongle will be radio1.

You will see two APs. One is original and there should be one disabled, which should be the newly detected settings. You need to try scan and set up this interface and use as client.

You can post screenshot so that I can tell how to do it in real.

1 Like

I did some work on this and with some help and hints from the OpenWrt forum I managed to set it up according to my needs, see RPi as a router.
I have some documentation AR300M as a yacht router.

It works nicely and provide a local wifi zone on board when the long range antenna connects to some wifi hotspot ashore. Same setup would work perfect for camping, RVs etc.

Regards,
Ole

1 Like

You need to try scan and set up this interface and use as client.

You can post screenshot so that I can tell how to do it in real.

Hi @alzhao , since the last days i tried to get the same thing running but failed. Can you give me some quick details on how to set up this interface? The documentation in the last post didn’t really help me.

Current status of my interfaces:

This is /etc/config/wireless : (radio0 is the USB WiFi)

config wifi-device ‘mt7628’
option type ‘mt7628’
option htmode ‘HT40’
option ht_txstream ‘2’
option ht_rxstream ‘2’
option hwmode ‘11g’
option noscan ‘0’
option txpower ‘20’
option txpower_max ‘20’
option country ‘US’
option region ‘0’
option band ‘2G’
option mimops ‘3’
option wmm ‘1’
option channel ‘10’

config wifi-iface
option device ‘mt7628’
option network ‘lan’
option mode ‘ap’
option encryption ‘psk2’
option key ‘goodlife’
option ssid ‘GL-MT300N-V2-eb1’
option wds ‘1’
option disassoc_low_ack ‘0’
option ifname ‘ra0’

config wifi-iface ‘guest2g’
option device ‘mt7628’
option network ‘guest’
option mode ‘ap’
option wds ‘1’
option ssid ‘GL-MT300N-V2-eb1-Guest’
option encryption ‘psk2’
option key ‘goodlife’
option ifname ‘ra1’
option disabled ‘1’
option guest ‘1’
option disassoc_low_ack ‘0’

config wifi-iface ‘sta’
option device ‘mt7628’
option network ‘wwan’
option mode ‘sta’
option ifname ‘apcli0’
option ssid ‘Airtel-E5573-5656’
option bssid ‘98:9C:57:28:56:56’
option channel ‘10’
option encryption ‘psk2’
option key ‘xxxxxxxxx’
option disabled ‘0’

config wifi-device ‘radio0’
option type ‘mac80211’
option channel ‘11’
option hwmode ‘11g’
option path ‘platform/101c0000.ehci/usb1/1-1/1-1:1.0’
option htmode ‘HT20’
option disabled ‘1’

I appreciate any help. Thanks you
ED

EDIT: I just realized that this thread is for a different router. I have the MT300N-V2. Does that work on my device?

replied you on your own thread.