Usb150 updated to 3.105 luci is not working well

I run pure openwrt and butcher my own code.

WAN access detection in this order ethernet, usb tether, WiFi.

WiFi scans a list of saved profiles. You can create more profiles. You will always have WiFi due to STA/AP problem.

Once WAN access is detected. Check for captive portal and add the site to rebind protection.

Once internet is established. VPN starts

I bring up 2 wifi AP, passthrough and VPN.

VPN AP always have killswitch and always tunnel DNS. No exception. It also detects lost of VPN and move to the next profile in the list.

All this is done without saving anything to flash and wear it down.

1 Like

Could you share the code?

There are no fancy GUI. A little Linux experience is required to set it up. Once setup it runs for days.

See if I can setup a GitHub.

1 Like

i understand your point, but imho, would not compare that zsun which, from what i read, is not ready for prime time and all the more so about your point “these should be travel routers, quick setup and go”

the pizero gets that done and so much more.

F: 3.211

Now GUI only allows to log in then I see only blank screen on my phone. On the computer it works but slowly as before.

Gl-inet, why are you killing your brand?

Your firmware is unusable!

1 Like

Do you mean USB150 right?

Yes, I mean USB150

I just flashed 3.211 on my USB150. I did a flash install because the firmware was very old.

I can access the web panel normally via pc and phone.

On my iPhone I used Chrome, Safari and Firefox. All worked normally and fast. I can login and have the correct page displayed.

One thing I did notice is: I always use Safari. So when I try Chrome and Firefox to open, the phone asked me if I allow the app to access device on my local network. I have no idea if this matters.

So if you could verify other browsers that may help.

Also try reset the firmware. Is this something work for you?

Hi, thanks for the answer.
I use an old phone with custom rom and browser and I don’t want to install any new browser. With every update GUI has been working worse and worse on my phone. On other my GL-inet routers I use clean Openwrt b/c a new GUI is a disaster but on USB150 I use official GUI b/c of ssids file. :frowning: This is the only reason of use it.

Perhaps I am wrong but in my opinions updates should improve experience but with GLi-inet is something opposite - unfortunately.

I like GL-inet’s hardware but the software is awful.

1 Like

Thanks for your update but I have no more comments.


if you have read this post, others including myself, have had issues with certain browsers and certain versions of certain browsers.
in my own experience, the firmware have been getting better in those ways.

your use-case seems very narrow - old phone running on custom rom.
so why not just find a web browser that works?

fwiw, each time you vent, we all get an email to our inbox about it.
so please, stop venting, find a web browser that works or start a new topic to solve this issue.

1 Like