Use AR 300M in hotel


#1

I’m trying to figure out how to connect my AR300M to the hotel internet via Ethernet tithe WAN Pitt, then connect my iPhone and iPad to the internet by using Wi-Fi from the 30m. I can’t find any information on this. I’ve got it plugged in using Ethernet, but I don’t know what any of the other settings need to be. This hotel has a splash screen when you connect, where you need to enter a password to access the internet. Can anyone point me in the right direction? Thanks.


#2

You can try as follow.

  1. Disable all VPN connections
  2. Disable DNS rebind protection
  3. Even then Chrome/Firefox might block the attempt to redirect because it will be expecting an ssl site. Please go to neverssl.com so that you get redirected to the captive portal.

#3

Is “DHCP client” the correct setting?


#4

Does you mean disable DNS rebind protection?

If so, you can refer to this instruction. https://docs.gl-inet.com/en/3/setup/mini_router/more_settings/#custom-dns-server


#5

I know for my AR300m, I was recently in hotel with ethernet (and the below method is similar when I do WISP mode).

  1. If you have switch set to controlling VPN, the latest firmware has a bug that doesn’t detect the switch on startup, so login to router and make sure you turn off VPN.
  2. Turn off rebind protection.
  3. Remove custom DNS servers. I found that having custom DNS servers setup prevented me from ever seeing the hotel’s captive portal. You can reenter them once you setup and working.

IIRC, this is the method I’ve used successfully. (I’m going off memory).

The other option, is go through the captive portal using device connected directly to hotel wifi and then clone that mac address to your WAN interface…if you are not comfortable with doing this, then I wouldn’t mess with it, but I’ve used that method successfully also. I’m on interface 3x…the update from about a month ago (I think 3.019 or something).


#6

Thank you. I’ll give this a try: