Use repeater mode as priority over 4G?

Im trying to use repeater mode (connected to my phone hotspot) as priority over the 4G connection. However it is not working. 4G is still the default when both are connected…
How can I configure the repeater mode to have top priority?

I also have the advanced interface installed. X750 is my router.

Could you please post a screenshot of your “Multi-WAN” setting?

im assuming you want the interfaces page from openwrt?

GL GUI → Network → Multi-WAN

My router doesnt have that network setting…

… that’s because the link I posted are the docs for the v2 model. Humm… I’m no use to you here.

You can upgrade to 4.x firmware GL.iNet download center

It has multiple wan management.

Ive updated the firmware. I was not aware of the new one. It looks like theres a priority in there I can adjust to my needs now.