Using API /repeater calls issue

Hi there,

I’m getting this when calling /api/repeater/info
{msg: "sta not configed properly", code: -108}

When trying to call /api/repeater/enable
# trying to set it up with /api/repeater/enable?ssid=SampleConn&enable=true
{msg: “ssid check failed”, code: -99}

And finally, when I’m trying to connect to a wifi via /api/repeater/join with params as follows:
# parameters to /api/repeater/join
ssid: neo
mac: B4:6A:AF:C5:A8:40
encrypt: psk2
issaved: true
channel: 3
device: mt7628
caps: UNKOW
save2uci: false

I’m just getting 500 error. May be that is because I didn’t specify the WiFi password, but I don’t really know what field to use to do such.
Is there something that I’m missing to do prior to use that calls? Or is there any other mistake? Any help would be really appreciated.

API version:
Custom firmware version 3.336


@lancer pls check it out

Hi, It seems that your firmware is not up to date. Which product are you using? Is the firmware standard official release?

  1. ‘/repeater/info’ only to show the current connection status. If the repeater is not connected, it will show “{msg: “sta not configed properly”, code: -108}”.
  2. We recommend upgrading the firmware to the latest. the ‘/repeater/enable’ will check the SSID parameter with wireless.sta config before, but not now.
  3. If you connect to an encryption network, the ‘key’ parameter is needed.
    Thanks for your feedback. We will do it better.

Thanks for reply, will check the firmware