Using GL.iNet GL-X3000 (Spitz AX) 5G NR AX3000 as a gateway to connect a smart lock via ttllock app?

I have a feeling I’m going to show just how little I know about all things techy, but here goes. I have added a new smart lock and it uses the ttlock app. I had a Eufy lock previously that I connected directly to the wifi, no problem. It died and the new smart lock I purchased to replace it refuses to connect to wifi. I am seeing discussion of connecting it via a gateway. The GL-X3000 is described as a Wi-Fi 6 cellular gateway. Does this mean there is a way to use it as a gateway to connect my new lock or do I need a separate gateway device? I have somehow managed to set up a number of smart devices (thermostat, garage door opener, door camera, several echo dots, etc.) all without a separate gateway device but am stumped as to how to add this lock. Any advice is much appreciated.

Your smart lock just need network to work. So pls omit the “Gateway” concept.

The reason it does not connect to your wifi is mainly due to encryption. Pls check the wifi settings on your router and try wpa/wpa2 mixed or just wpa2. Choose whatever option it works.
Generally wpa3 may not work.

Alzhao,

Thank you so much for your reply. It was set on WPA-PSK and I changed it to WPA/WPA2-PSK. Unfortunately I am still getting “Operation Failed” when I attempt to Configure Network and enter the wifi password. I am using 2.4G and so I am at a loss. Maybe the lock is defective? Any other suggestions? Thanks again for your help with this!

Also try WPA2.

What wifi channel are you using? Pls only use 1, 6 or 11. Do not use others e.g. channel 3 may notwork with a lot of iot device.

I tried WPA2 and all 3 channels but still no luck.

Can you get the logs after your camera failed to connect?

Thanks so much for your reply. We are out of town at the moment returning tomorrow evening. I might need some guidance on how to do that, but w I will try to send it tomorrow evening. Thanks again!

  1. Connect your cam to the router, wait it failed
  2. log in the router’s admin panel->system->log and export the log.

I’m so sorry for the delay in responding. Here is the log. Please let me know if you come up with anything. I tried adding the lock many times, including just before exporting the log, so hopefully there is something there. I` even purchased another of the same lock in case the one I had was defective, so there should be a couple of different locks on the log. Again, the app I am trying to add the lock through is TTLock and the lock is a Reyoll Smart Lock, 7-in-1 Keyless Entry Door Lock from Amazon and is linked below. Thank you for any help you can provide.

logread.tar (197 KB)Reyoll Smart Lock, 7-in-1 Keyless Entry Door Lock

In the log there is one device cannot associate.

We will find some IoT sensors to test.

Thanks so much for your help!!

Please try the move the router close to the door to see the connection to check to see if the signal is weak.

Pls try this operation.

sed -i s'/G_BAND_256QAM=1/G_BAND_256QAM=0/' /etc/wireless/mediatek/mt7981.dbdc.b0.dat 
wifi down
wifi up

Thanks again for your help! Right now we are on a cruise and will be back home on April 15th. I will try your suggestion then, but could you give me a bit more detail on how to proceed? I am far from tech savvy. Thanks again!