Using MacBook Pro between GLAXT1800 and Cruise Ship Wifi

Hello, I’m on a cruise ship and I have the GLAXT1800.
I can’t connect to the ship’s WIFI using repeater mode because i need to enter info like name, DOB, and email. However, I can connect my MacBook Pro (OS Ventura 13) to the WIFI.

How do I connect the AXT1800 to the MacBook so that I can get to the internet via the Macbook?

If you want to use the AXT1800 to repeat your MacBook’s hotspot for Internet access, the MacBook must support hotspot sharing while connected to Wi-Fi. I’m not sure if your MacBook supports it.

I would recommend trying to repeat ship’s Wi-Fi with the AXT1800 first. For authenticated Wi-Fi please refer to Connect to a Hotspot with Captive Portal

Thanks for the reply.
I’ll check out the suggestion.

You are not redirected to the captive portal on the ship when you connect via your router?
If this does not work at all, login with your Mac and clone the MAC-Address on your router.

Also be aware that you are on a ship and the Cabin storewards will unplug devices that are left unattended in rooms such as computers, laptops, cell phones and travel routers.

Thanks for your email.
I tried following methods 1 and 2 from Connect to a Hotspot with Captive Portal
but the login screen does not pop-up.

There are 2 more ways to connect to the portal if the automatic way does not work at all.

  1. Connect your Mac and copy the URL that it connects to. Then use that URL when you are connected via your router.
  2. Connect via router and log to the Admin Panel of your router. When you are connected to the ship’s wifi you will find the gateway IP address. Copy this to your browser and try to connect.

hope this helps…

Thanks for the suggestions, Marcus.
I tried 1 & 2 but they didn’t work for me.

!. The URL was
I entered it into my browser and an error message came up saying that DNS cannot be found.

  1. The gateway was
    I also entered it my browser and error came up as unreachable.

Thanks again.

FYI, The cabin stewards did not unplug the AXT1800.

Thanks for the emails.
I’ve logged in to the ship’s WIFI using the Mac.
How do I determine the MAC address of the ship’s router?
How do I clone that address on the GLAXT?

No, you clone your own Macbook’s MAC Address to the GL.iNet, disconnect your Macbook from the ship’s router and then connect your GL.iNet to that router instead. This way the ship’s router will treat your GL.iNet as if it is your Macbook.

Hi Leslie,
the mac-address of your mac is: A4:83:E7:CB:14:47 just found it because it was coded into the url you mentioned above :wink:

Should be called MAC Clone or MAC Address. Use A4:83:E7:CB:14:47 and connect to the ship wifi with your router again. Make sure your Mac-Laptop is disconnected from the ships wifi, because it might cause problems when two stations with the same Mac-Address are active.

Just to make sure that this is not a problem. Did you connect with a VPN before? If yes, disable the VPN at least during the initial connection. Same for DNS settings. If you made manual changes there, reset them.

Not really related, but cabin stewards are usually not allowed to touch your electronic things, because if they do, they might break something.

Hope this helps

Thanks. I understand that better now.

Thanks, Marcus.
Still no go. I even tried using RANDOM MAC clones (allowed by the GLAXT).

So obviously there is a problem picking up the captive portal. Mine worked at last hotel but not at this one of same hotel chain.

Usually going to IP of hotel router works. But not here. Having read the instructions, found another setting. Now working. This needs to be in the official guide.

Connect the your device to travel router wifi. Turn off vpn. Try pointing browser to hotel/ship router.

Override DNS Settings for All Clients - set to ON.

(Note plug in ethernet and wifi hotel/ship routers have different IP. But both working. Should be able to failover.)

1 Like

Thank you very much, bluey.
It worked!!!

Is it just disabling vpn?

As other settings are already the default.

What did you mean by that? How does one point their browser to hotel’s router?

When connected to wifi or plugin captive portsl network with no internet, check details. You should have an ip address and a router address.

When the automatic portal login page fails to appear, often putting in the ip address of the portal router will trigger it to display.

Eg in the dot notation form

1 Like

This was not default on mine.