Using particular radios for WISP and internal connections

I’m sure I found instructions on how to do this in the forums, but my search is failing me. Sorry for asking a duplicate question.

I have an AR750 set up in WISP repeater mode. I’d like the 2.4Ghz radio to be connecting to the WISP/external network, and the 5Ghz radio used for the internal network that my clients will connect to. However, by default it seems to set up the other way around (as soon as I select WISP, the 5Ghz radio seems to connect to that network).

I couldn’t see any way in the UI to control this. What am I missing?

Does your 2.4G and 5G has the same SSID? If they have different SSIDs you can chose the correct SSID to connect.

Disclaimer: completely new to Openwrt and Gl.iNet. I have a AR750 on the way I hope to use with hotel networks when I travel.

Curious why you wouldn’t you want to use the 5GHz radio for the WISP connection? I’m thinking a faster WAN connection with maybe less congestion using 5 GHz.

Bump. I also have an AR750 on the way and wanted some answers to updated information to the previous questions. My main reason for purchase is being able to connect to the hotel/cruise ship Wifi on one band, and distribute the signal to my wireless clients on the other band - in hopes of avoiding the speed degradation of both the TX & RX signals being on the same band. I’m hoping the AR750 can do this, because my current travel router (Trendnet TEW-817DTR) cannot. Netgear calls the capability “FastLane”.

@tk421 The reason one might want to use the 2.4 Ghz band for the WISP connection is if there is no 5 Ghz signal available, or the signal is much weaker than the 2.4 Ghz signal.

To get any AP scanning precision (ie, frequency, bssid, connection quality) when you’re in a place with 100+ APs like me, and esp. when they use the same SSID for both 5G/2.4G, you really can’t do it with with the GL web interface – you need to do it with with either Luci (ie, Advanced) or via command-line. However, even after doing an initial setup using 2.4G for WISP, one thing that drove me crazy is that various “re-scanning” tools kept forcing my setup back to using the 5G radio at least once per day, which caused disconnects, and also drastically reduced my speed. So now whenever I do a full rebuild, I do the following:

AFTER doing an initial WISP setup using the GL web tool:

  1. Uncheck “Auto scan & reconnect”. Although, it still seems to rescan even when unchecked.
  2. In SSH session, disable “gl_health” process by commenting-out the line calling it in “/etc/rc.local”. This is the main culprit for constantly re-scanning and changing the “wireless” config, and causing disconnects and speed drops. I’d recommend anyone having disconnect issues to disable this “gl_health” process on startup. After disabling it in rc.local, you still need to manually kill the active process or reboot the router.
  3. I have a template “/etc/config/wireless” config file that I copy over the existing one. I’ve had to fix this so many times that I find it easier to just copy my template rather than using Luci/uci (I even had a cron job do it, until I found that “gl_health” was the culprit). If you manually change this file, you can reload the config with the command “wifi reload” or by rebooting.

Below is what my “sta” (WISP client) section looks like in “/etc/config/wireless”. Using “radio1” means using the 2.4G radio vs. “radio0” for the 5G radio. The “gl_health” process kept changing this back to “radio0”, among other things. Note that the “bssid” line is only needed if (like me) you want to connect to a specific AP – otherwise, remove that line. And of course, you’d need to adjust the “ssid” and “key” lines appropriately to your WAN (WISP) network.

config wifi-iface 'sta'
	option device 'radio1'
	option network 'wwan'
	option mode 'sta'
	option wds '0'
	option ifname 'wlan-sta'
	option ssid '<WISP_SSID>'
	option key '<SSID_PW>'
	option encryption 'psk2'
	option bssid '<AP_BSSID>'
	option disabled '0'

My two radio sections in “/etc/config/wireless” look like this below. Note that the txpower for 2.4G is “0”, since there’s no point if using this radio only for a WISP connection. Also note that using “VHT40” over “VHT20” for radio0 makes a difference in speed if your WiFi devices support it. Using “VHT80” doesn’t really help for Internet throughput, though, unless using “HT40” for radio1 – but that is really only possible in a “greenfield” env like a rural area. In any congested area, you pretty much have to use “HT20” for radio1. Also, adjust the “country” line if applicable.

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option band '5G'
	option htmode 'VHT40'
	option hwmode '11a'
	option channel 'auto'
	option doth '0'
	option txpower '20'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option hwmode '11ng'
	option channel 'auto'
	option txpower '0'
	option country 'US'

EDIT/UPDATE: They actually did some work recently in my building on the APs I connect to via WISP, and afterwards, I seem to be able to get similar speeds for both WISP at 5GHz (20MHz width) and 2.4GHz WISP (20MHz width), topping-out at the same peak speeds (likely both limited by the 2.4GHz, regardless of which one is WISP).

For what it’s worth, these are the speeds I get. As a comparison, when using 5G for WISP (limited to 20MHz channel width by my building’s APs), and all local devices connected to the GL router via 2.4G, I could only manage ~40Mbps download speed. The AP I’m connecting to is only ~3m away inside my apt on the ceiling and in complete line-of-sight (no walls in-between), so even with a close-by AP, I get much better results with 2.4G WISP than with 5G WISP, and wouldn’t assume that 5G WISP is better.

Baseline speed with phone/laptop connected directly to my building’s AP via 5G (no GL router):

  • Best speed tests: ~90Mbps download, ~105Mbps upload

Speed with phone/laptop connected to GL router via 5G, and GL router connected to AP via 2.4G WISP:

  • Average test for phone with AC: ~75Mbps download, ~60Mbps upload
  • Best tests for phone with AC: Several tests at ~90Mbps download, ~70Mbps upload
  • Average test for laptop with N (no AC): ~65Mbps download, ~60Mbps upload
  • Best tests for laptop with N (no AC): Several tests at ~80Mbps download, ~65Mbps upload
1 Like

Also, here are some commands for scanning specific radios:

Scan SSIDs specifically on the 5G radio:
# iwinfo wlan0 scan

Scan SSIDs specifically on the 2.4G radio:
# iwinfo wlan1 scan

Or, if there are way too many SSIDs in your area, and you want to filter and see only the ones with a connection quality of 50 or more, something like this:
# iwinfo wlan1 scan |egrep -A1 -B3 "ity: 5|ity: 6|ity: 7"

Fabulous post Mr Bluegreen, that bit that interested me was how to turn off GL Health.
Perhpas Alzhao can comment on how safe, or otherwise it is to turn this off (for info, my set-up is WISP and VPN always on).

I thought about that too – what i’d be missing with disabling gl_health. It’s a binary, not a script, so i couldn’t look at what it did. In the end, I decided that it isn’t any worse than running a “clean” image or “stock” openwrt, so I kept it off. I haven’t noticed anything negative so far (a month or so).

I also wondered if the checkbox in the GL web tool for “re-scan” interacted with gl_health, but wasn’t working. It caused two issues for me: it would change the “wireless” config from radio1 (2.4G) to radio0 (5G) at least once a day, and would also frequently change the AP BSSID, which also hurts my performance, since I have an AP in my apt, and using any other AP in the building is slower.

Incidentally, I tried several other WISP routers from other companies, and all of them had similar issues and behaviors – they would frequently drop connection or change radios and/or the speed would drop drastically. But since they were closed/proprietary firmwares, you couldn’t do anything about it. That’s the great thing about the GL ones’ using openwrt – at least when an issue does come-up, you can investigate and tweak things like this. And since my tweaks – so far, so good. Definitely the best WISP router I’ve owned.

1 Like

Thanks for sharing blulshgreen.

gl_health tries to monitor repeater connection. This is quite necessary in the 1 radio routers. When repeater cannot connect, you will have no wifi to configure. But now you have two radios, you can alway have one AP on even if repeater fails.

There are some strange behavior of ath10k than ath9k, which cause big problems for gl_health. I believe there are some problems and we are improving that.

All gl_health did is to monitor repeater status and choose an availble SSID to connect.

Even you choose not to check “auto scan and reconnect”, it will tries to disable repeater if it breaks many times.

If you do have good OpenWrt skills, just disable it by renaming the /usr/bin/gl_health process and remove it from /etc/rc.local

1 Like