V3.00 firmware for MT300 A and MT300N V2

@kyson-lok. Hi Kyson, so port forward just port 51820 on the main router to miniserver?
Yes I mean I address on Wireguard Server (miniserver)
Yes I mean allowed IP addresses on Wireguard settings

Could you possibly post a real world example config that would show Wireguard running on 2 mn300 routers connected? That would be most helpful.

Ok, so I’ve worked out part of the issue, I hadn’t used the static IP on miniserver from my main router - miniserver now has and this is now in the config.
Copied config to miniclient - no go
Added port 51820 to main router and forwarded to miniserver - works!
Changed DNS settings on both miniserver and miniclient to Cloudflare and - still works!
So the mini server and client can now see each other and have some data passing across. Unfortunately I can’t access internet yet via vpn - very very slow connection. No internet via vpn.
I’ll continue working on this. If anyone has any suggestions I’d appreciate it.

I’ve given up with Wireguard for the time being. Got system up and running very quickly with OpenVPN and it does what I need it to do; namely to use one v2 as a server connected to my home router and the second v2 to connect via internet to home router and use that ip range for internet access (I want to wat can BBC iPlayer anywhere in the world and this is the ideal solution - using my home router ip for that)
Will try Wireguard in the future when it’s a bit more newbie friendly.

Thanks all.


Just an update on the performance of the gl-mt300a-3.005-1024.bin. It works well as a client for OpenVPN,
Wireguard and Shadowsock but I had real problems in multiple hotels getting it to logon to captive portals (where you have to sign on a web page after connecting to the wifi access point)

I turned OFF the VPN, unchecked the “dns rebind” setting and disabled Cloudflare DNS.

Although I could connect to the hotel WiFi I could never get the captive portal to load. I even tried cloning my android phones’ MAC (which connected and got the portal page every time) but this caused the MT300A to lock up.

When I flashed the latest stable 2.264 firmware the captive portal always came up.

Can you please look at this as it is key feature which prevents me using the otherwise excellent V3.00 firmware.

Can I suggest that when the dns rebind is deselected the cloudflare dns should automatically be deselected as well.

Looking forward to further updates,