V3.00 firmware for MT300 A and MT300N V2


#1

I know that we should be patient but when can expect this ?

I recently tried a v3 firmware on the MT300N V2 which was temporarily on the firmware web site and it worked well as a Wireguard server (unfortunately Wifi didn’t work).

I haven’t posted any comments or bug reports (as I subsequently read that until the v3 firmware is formally released it is not suitable for end user testing) but this this firmware looks really exciting !


#2

MT300A has http://download.gl-inet.com/firmware/mt300a/testing/

MT300N-V2 does not. We did put the firmware there but there is problems so we withdraw. But we will test and put there soon.


#3

Thanks Alzhao is the MT300A V3 firmware ready for end-user testing ?


#4

I think so. If you have MT300A pls try.


#5

I have both MT300N V2 and MT300A so will do thanks


#6

Just an update trying the V3 firmware on my MT300A.

It is working well as both a Wireguard and Open VPN client via Wifi, USB tethering to a mobile phone and as an AP via Ethernet.

However it is impossible to change the Wireless channel and modes using the GLi interface - however you can change these parameters using the Luci GUI.

Please keep up development !


#7

Thanks for your feedback. Will investigate it.


#8

Hi alzhao, desperate for v3 for mt300a-v2 firmware as I’m completely lost with trying to get Wireguard running on terminal command lines.
Could you please let me know when you are going to release the update?

Thanks
M


#9

Surely will provide this week. @kyson-lok pls help!


#10

Just an update I tried the Shadowsocks Client (using the 750S install instructions) on my MT300A and it works very well with my home Shadowsocks server.

Latency with Shadowsocks is very high 1000mS compared with less than 100ms with Wireguard on the same route. Is this just due to the protocol ?

Looking forward to further updates to V3

Thanks,

Pseudonoise


#11

@MarcusB MT300N-V2 testing firmware is ready. Pls have a test.


#12

Hi @kyson-lok I apologise for being stupid to start with.
My setup: 2 x M300N-v2 routers

1 connected to home LAN - router named MiniServer
1 connected by Wi-fi to an android phone with data hotspot - router named Mini Client
Both routers have internet connections.

I set up MiniServer as the server and is attached to lan via cable.

I set up MiniClient as the client that I want to be able to travel with.

I’ve followed the instructions on v3 for the installation of Wireguard and I think I get it however I only get a yellow/orange status button and an Abort button. I don’t seem to be able to make the connection.

Could you please confirm that I’ve got these the right way round - server and home, client to travel? I’ve tried both ways and the same result.

I have not made any other changes,
Interface IP is 10.0.0.2/32
Peer allowed IPs are 0.0.0.0/0
DNS is blank

Could you please tell me what I’m doing wrong? Really frustrating.

Many thanks

Marcus


#13

Just updated to the latest V3 MT300N-V2 testing firmware.

With the MT300N-V2 as a wireguard server i have dns leaks - whatever setting I select in the MT300N-V2 Custom dns server menus .
I have enabled the following -
DNS Rebinding Attack Protection
Override DNS Settings for All Clients Help
DNS over TLS from Cloudflare

and still my mobile network’s DNSs are shown on http://ipx.ac/ and dnsleak when a wireguard tunnel is operating.

Any ideas ?

thanks,

Pseudonoise


#14

Does your miniserver has internet IP and can be accessed in the rest of the world?

Ensure it can be accessed from internet. If it is not main router pls set up port forward in your main router.

Check in the client router if the IP info is correct.

You can also use wireguard app on smartphones to check if server is enabled.