Vanilla OpenWRT on E750C6?

Hello - is there a way to flash clean OpenWRT image on the E750C6?

I see a commit with discussion about the E750, but the specs on that differ somewhat from the E750C6. I am not even sure what different versions of the E750 exist, though. I’d like to get a vanilla OpenWRT installed. Thanks for any help!

Or is there source code for the existing images?

Or even a list of the different models of E750 that exist? I can’t find much documentation about these. Super cool hardware! I just want to know more and have full control over it.

Here you can find directly

Thanks for the link! Before I got that, I tried to uboot with a different image. That attempt seemed to ‘freeze’ partway through and never finished. I was able to power the device off and when I started it back up, it came up just fine in the normal (original) interface. When I try to access the UBoot method now (power off, press and hold reset button) the display shows “Please Open Web”, but I am not actually able to connect. I set a static IP for my ethernet,

I’m still able to connect on in the regular mode on the router, but when I do uboot mode it seems to not respond on Could my failed earlier uboot attempt have jammed up just the uboot side of the device? Is there any way to fix that, if I did?

Pls make sure you set up netmask to
Also make sure cable is connected before powering on.

I have the netmask set, and tested both ways: cable connected before powering on, and connecting cable after power on. In either instance, the display goes to “Please open web” but then the device doesn’t respond.

Could I have bricked the uboot functionality? Is there a way to apply the vanilla OpenWrt through the web ‘upgrade’ function on the normal system?

You have to connect cable BEFORE power on. Connect cable after power on does not work.
But this may relate to the network card etc. So not sure about the reason.

Surely you can do this. Do not reserve settings.

Okay! I was able to get the web interface for UBoot connected again. Thank you! Having the cable connected before power on was the key – I guess I hadn’t done that before.

However, when I flashed the image, I got the same result: it seemed to flash, and then the router rebooted but froze on “Booting” with four little dots left on the loading bar.

I tried again, with the same image:

I verified the SHA-256, it matches the 7116…d8 as listed on the OpenWRT page. Through the UBoot web interface, I can start that flash. It seems to take it, the device reboots, and starts the “Booting” loading bar. That goes most of the way, but then hangs on the last four dots.

I’m using a GL-E750C6.

I re-flashed the image from the GL-Inet website:


That restored back to normal function. I could boot and use the normal web interface just fine.

Through the “upgrade” function on the normal web interface, I tried to install either of the other versions from the OpenWRT site but they came back as “incorrect firmware format.”

I appreciate all your help with this! What am I missing at this point?

Seems the openwrt image has problems. Will check.

Any updates on this? I note that the SHA-256 has changed on the openwrt site. Does that reflect an updated version of the software?

Well, from today’s testing – maybe updated, but still not working. :slight_smile: