Velica (GL-B2200) - Openwrt update bricking issue

Hello Brains Trust,

I have a peculiar issue with my Velica (GL-B2200) units (x2), which arose after reading up on the recent patching that allowed Openwrt release updates. I followed the commit as it mentioned (it has a weird typo of ‘gunzipped’… I assume that’s a typo?), and the only issue, I believe, was me messing up the initial step of using the openwrt install file over the sysupgrade version. No big deal I thought, so I followed the Uboot debricking instructions provided here, but just as is my luck, I cannot for the life of me, get any connection happening via network cable or wifi following a supposed stock firmware reflash. I have emailed a nice tech from Gli.net who has tried to give me links and advice, but I still can’t seem to solve this puzzle.

I can follow everything in order to get me back to the Uboot page, but that’s all I can do, and I’ve attempted every variation to get things working again. The only thing I haven’t tried is a very early (perhaps release edition?) release of firmware.

It was mentioned in email tech support that I use the App to bring them back online, but that didn’t make sense to me, as a stock firmware flash and reboot, straight reset etc should bring wlan’s back online, or at least a pure ethernet connection direct… but there’s just one light on the unit/s and nothing happens. No available SSID and no available cable connection possible (other than reaching Uboot menu). *The app doesn’t help any, btw.

Does anyone have advice? I am really surprised by this. Is it possible I have totally bricked both devices?

So you can’t get the latest stable stock firmware to load via uboot?

https://dl.gl-inet.com/?model=b2200

That is correct, Limbot.