Verizon blocking GL-X3000

Verizon says GL-X3000 is not approved and is blocking connection. Modem is the Quectel RM520NGL. Any suggestions?

I’m not having any issues with my Visible (Verizon MVNO) sim. I did at one point change the IMEI of the X3000 to that of my Pixel 6a. I may have changed it back to the original though. I’ll check. Make sure to write down the original IMEI if you do try changing it (instructions are available in this forum). Have you successfully used the sim in a phone? That would be step 1 in troubleshooting this. Are you running the latest stable firmware? Have you confirmed the correct APN settings on the X3000?

Edit: Just checked and I’m actually using the IMEI from my Pixel 7. I’d still recommend checking all the items I mentioned above first before changing the IMEI.

Using Version 4.0 release 50402.

Started with sim from old Jetpack. The GL-X3000 worked fine. I Was getting 4G at my house (8 Mbps down 1.5 Mbps up). I took the device to a friend’s house and immediately connected it to 5G (25 Mbps dn & 6.5 Mbps up). Better speeds than I get with the Pixel 6 or with Jetpack.

Returned home and turned the unit on and got a text from Verizon, “We have detected that you have relocated your sim to a different device.” I had to contact customer support. They said VZ doesn’t allow sims to be moved between devices for security reasons. The tech said there could be an issue with my unit because it was not VZ certified, but he thought it would work. Since my sim card was several years old, he thought a new sim might be helpful and sent me a new one. When the new sim arrived, I called tech support, and they activated the sim through my Jetpack. Moved the sim to the X3000 and it would not connect to VZ towers. The router can detect several 4G and 5G towers but their system won’t let me connect. Again, the VZ tech said the device was not approved and VZ’s system will block it.

Confirmed with VZ that the MTU should be 1428. Could not get any info on the APN. I have tried several but not been of any help. The APN is currently set to VZWINTERNET.

If I hack the system by changing the IMEI does that affect both sim slots?

Exact same issue on ATT. They said its not compatible. And locked the sim so it wouldn’t even work in the original device until i called in. Changing the imei would do both slots and would likely fix the issue. But be aware it’s illegal in some areas and definitely against TOS. And they can and will cancel your service if they detect it.

If you spoof the IMEI make sure to lock in only the bands the donor device supports and that the donor device doesnt connect to towers or turn on to be safe… This will be a huge red flag

Perhaps Verizon uses a shorter leash than Visible. Your APN is correct. I’m not sure if the IMEI affects both sim slots or not. I would try using the Jetpack IMEI with the X3000. Make sure to issue the following command after changing the IMEI to save it.


The cellular settings that I am using are:
Protocol: QCM
Port: /dev/mhi_QMI0
Pin, TTL, TTL IPv6 and MTU are left blank.
Authentication: NONE

I am not doing anything with band locking but the Pixel 7 (donor IMEI) and the X3000 both support all of the Verizon bands excluding mmWave.

Edit: When I moved my Verizon sim from my Pixel 6 to my Pixel 8 a few weeks ago no Verizon security intervention was needed.

You shouldn’t need to mess with any setting beyond the apn as the router should auto negotiate with the tower.

If you bought the phone on contract then it will most likely have a sim lock attached to it at the provider end for preventing theft and fraud. In my opinion the IMEI spoof will probably need to be assisted with a mac spoof to match the original device or the lock will trigger. The router brand shouldn’t be a problem as they all use the same ISO standard to connect. It is a universal industry wide preset.

I suspect that the security will also trigger if you put the sim in another phone and move to another location as it would red flag for a theft.

The IMEI should affect both slots because dual sim devices. If you have 2 fields then I’m obviously dead wrong as I’ve never handled your type of router before…

Good catch on the MAC address. I have mine set to manual and must have clicked the random button as when I do a lookup I get record not found/no matches.

I think you’re correct on the single IMEI value as the X3000 only has one radio/modem (not sure the proper term here) and does not do DSDS. I have confirmed this by switching to sim 2 and it’s displaying the same IMEI number.