Verizon sim in GL-X1200 with EP06-A stuck on "SIM not registered"

This sim has been working perfectly for the past several months, then on day it got “deregistered” and I cannot do anything to get internet back through the cell modem. I’ve tried the sim in both a GL-X1200 with a EP06-a and an EC25-AF as well as a GL-X750 with a EP06-a. All to no avail. I have tried the sim in a verizon hotspot and it works just fine, so not sure if verizon has now banned Quectel modems or something.




both report


+CGREG: 0,2


Verizon has a two-step approval process. First the manufacturer has to get the device approved. Then the vendor of the end-device has to get all the IMEI white-listed. If you bought your ep06 from Gl-Inet the second step has not happened. Verizon started to kick such devices off the network over the past months. The only thing you can do is to change the IMEI or get a fully-approved modem. Or to switch to a network that doesn’t have such stupid rules/hurdles.

Looks like your modules are supported -

Is it an APN change?