Very Urgent: Question about RESTORE A BACKUP

Sorry for the urgency.

We do have a AR300M which was reset to factory default at customer’s premises (by the other side of the world).

My question: If I do a RESTORE of a backup (via luci), will be restored everything ? I mean including VPN .ovpn file, credentials, logins etc ?

Actually client made a complete reset and I don’t wanna go through to set it up again.
He is also not able to forward port 83 to point to the router installed in our machine (from his main internet router).


  1. If I remember correctly, all of the standard stuff (ie. what you see in the GUI) is restored including the ovpn files etc. Since it is urgent and you appear to have no other choice, why don’t you try and see for yourself?
  2. Need more details on the port 83 problem - you mean it was enabled and didn’t work or?


First of all thanks for your reply.

Yesterday night (at the time I posted) I didn’t have any GLnet router with me so I can’t try. Just back office and tried it. NOT WORKING.

I open a new AR-150 and set it up quickly (just language/time-zone/password).
I went straight into LUCI (advanced settings) and tried to upload a back tar file we did before shipping the machine. The file (compressed is 159KB).
Waited to reboot but nothing is restored: no VPN profile, no PORT FORWARDING, nothing at all.

Here is the screenshot of the directory files from the untar backup archive:

As you can see there is the .ovpn file but nothing change inside the AR150.

This is the screenshot after the restore process, for example OPVN:

I wanna send the backup***.tar to a technician there and have it restored locally as I don’t have remote access to it. Port 83 is enable but my client is not able (he doesn’t know how to do) to port forward (open) port 83 in its main office router to point to my GLnet.

I just tried the command line as this:

After done, before rebooting, it was working great. All files back to their position.

I done a reboot and it hang. 10 minutes no sign of life.

I have to redo a factory reset and then it is back in life but of corse without my settings.

Any suggestion ?

Are you restoring a back up from AR150 to AR150? You talked about AR300M before. So don’t mess up models.

My client has an AR300M.
We don’t have AR300M in stock only AR150
So I made a test using a backup from another client with AR150 restoring it into a new AR150 from our stock.
AR150 backup into a new AR150
Sorry if I didn’t clarify it enough.
Anyway for your information.

(1) Command line IS WORKING.
I found that it’s working only if I use the ‘-C /’ at the end of the 'tar -xvf…"
Without seems not working

(2) Via LUCI (web) IS NOT WORKING.
It doesn’t restore anything at all.

(3) I tried a TPLINK MR3040 with OPENWRT.
I did back up and then I reload the openwork image to be sure that will be as default.
Restore via LUCI (web) IS WORKING.

(1) AR150 via SSH command line : restore working
(2) AR150 via LUCI (WEB) : restore NOT WORKING
(3) TPLINK MR3040 via SSH command line : restore working
(4) TPLINK MR3040 via LUCI (WEB) : restore working

Small note on this response. Just tried to restore via backup on my Beryl, and it didn’t like the zipped archive with the .tar extension.

So, from the command line, I did the following:

cd [directory-containing-backup]
tar -xzvf [backup-file].tar
tar -czfvf [any-name].zip

After this, the restore from backup worked just fine with the file wearing the .zip extension. Note that @brokenby2703’s note that the -C flag appears to be necessary if trying to tar/compress from a directory different than the one the backup file to be extracted is within. I did not verify this, but can say that my solution above worked for me.