VLAN configuration WAN port (GL-AX1800 Flint)


I recently purchased the Flint router (GL-AX1800) with which I want to replace my old Asus router.

I currently have internet with DIGI (Spain) which installs an ONT + Router (currently replaced the router of the provider by the Asus). For the internet connection to work I need to be able to configure the WAN with vlan 20.

I have seen how to do it on other GL.inet routers but I have not been able to do it on this one. In Network > Switch I can enable the “Enable VLAN functionality” check but it does not let me add any VLAN in any connection.

How can I fix this?

Thank you.


Can nobody help me?

On the Asus Router I did the configuration like this

As you can see, VID 20 is required for internet to work. Can’t this be done on the GL-AX1800?

Unfortunately I’ll have to return it if this can’t be fixed.

It’s not supported to configure vlan at webUI. Please try set vlan by command line:

uci set network.wan.ifname=eth0.20
uci commit network
/etc/init.d/network restart

I also have DIGI you can do via webgui using LUCI I followed this post: How to configure WAN VLAN on MV1000 Brume? - #3 by l3db3tt3r

You can use my config file to compare it with yours

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘’
option netmask ‘’

config globals ‘globals’
option ula_prefix ‘XXXXXXXX::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘lan0 lan1 usb0’
option proto ‘static’
option netmask ‘’
option ip6assign ‘60’
option hostname ‘GL-MV1000-d1d’
option ipaddr ‘’

config interface ‘wan’
option hostname ‘GL-MV1000-d1d’
option metric ‘10’
option proto ‘pppoe’
option username ‘XXXXX’
option password ‘XXXXX’
option disabled ‘0’
option ipv6 ‘auto’
option ifname ‘wan.20’

config interface ‘wan6’
option ifname ‘wan’
option proto ‘dhcpv6’
option disabled ‘1’

config interface ‘lan0’
option ifname ‘lan0’
option macaddr ‘XXXXXXXX’

config interface ‘lan1’
option ifname ‘lan1’
option macaddr ‘XXXXXXX’

1 Like


I will try it this weekend and let you know if it works.

Thank you very much!

Just out of curiosity, did you manage to set up VLANs on Flint?
I am considering buying this device and VLANs is must have functionality for me.

I have not been able to get it to work. I will have to keep trying. I will let you know if I get it to work.

hi, wonder how to run command lines? do I need run codes on PC (Win), or other devices like Mac/iPad etc? thank you.
I am stuck with Dodo FTTC NBN connection, VLAN is 100

Dear user, to run command lines in router shell, FYI, SSH to the Router - GL.iNet Docs

The command line works for me. Thank you very much.
For me, I just modified VLAN for 35 (Orange FTTH).

1 Like