Vlan tagging in B1300 in the WAN port

Hi! I just bought a gl b1300 router. I’m using stock openwrt.

My home internet configuration requires vlan tagging on the wan port in order to be able to connect to my isp. However, there is no vlan option for the wan port, only for the two lan ports (and cpu).

Why is this happening, and is there a way to do achieve what I want? I’m quite preocupied as I bought the router thinking everything would work out and now I’m not able to get vlans in that port :frowning:.

I have no problem in doing this in the command line, if this is just a problem with the web interface.

Thanks!

it is available in Luci under more settings > Advanced.

Network > Switch

sorry, can’t seem to find “more settings > addvanced”. ( @reflector it seems you were talking about the glinet interface, but I’m already using stock openwrt, so I only have luci )

when I go to “Network > Switch” (http://192.168.1.1/cgi-bin/luci/admin/network/switch)

I see only

which doesn’t include vlans for wan.

no help whatsoever? I’m really lost, every tutorial I see on the web allows for tagging the WAN port, I don’t see why my router doesn’t

my 750s has it. try tagging it on the CPU?

that doesn’t seem to work…

I found this IPQ40xx Switch Config "Strangeness" - For Developers - OpenWrt Forum, which is somewhat similar. But still, doesn’t seem to help.

If it’s some driver issue, this means that the hardware is incapable, or that the driver was written without supporting this option?

Hi, in stock firmware, following configuration make B1300 wan as vlan 88.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ieee1905managed '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config interface 'wan88'
        option ifname 'eth0.88'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '88'
        option ports '0t 5t'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '1'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '2'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '3'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '4'
	option mode 'dscp'
	option status 'enable'

config switch_ext
	option device 'switch0'
	option name 'QosPtMode'
	option port_id '5'
	option mode 'dscp'
	option status 'enable'

After burning a lot of time on this issue, I found out that with the stock firmware, vlans will probably work, as long as you don’t use id=1 or id=2.

Unfortunately my ISP requires vlan id=2.

From what I can tell, this limitation is partly due to the qualcomm chip, but mostly due to a poorly thought out linux driver.

So I flashed OpenWRT (snapshot version), where a workaround is possible. For instructions, see my post to the OpenWRT forum thread here: IPQ40xx Switch Config "Strangeness" - #66 by rvl - For Developers - OpenWrt Forum

1 Like