VPN and GL-iNet cloud (remote control)

Hello,

I’ve been using a GL-SF1200-093 modem for about one week. It’s working really well but I have a small problem with remote control over the cloud.

I use a VPN with the Wireguard protocol to secure my connection and it seems to be the cause of the cloud being unable to detect the device remotely.

Can I change some parameters in order to solve that issue?

Thank you

Try this

Hello,
I use an AR300M and an AR750 in GoodCloud. But as soon as I turn on VPN on AR300M via WireGuard I can’t access the remote network from AR750. The settings are according to the instructions “GoodCloud and VPN”.

Details please. e.g. the subnet in each node, the subnet of your wireguard.

Hello,

the settings of the subnets are all correct, I have just tried it several times (Main-Node: 192.168.xxx.1 and Node1: 192.168.yyy.1). The connection works from xxx to yyy. Meanwhile, VPN is running on Node1 via WireGuard. Everything works without problems.
As soon as the main node is connected to a VPN provider via WireGuard, access to the Node1 network is no longer possible. Tested with ProtonVPN and Trust-Zone.
An exclamation mark is then displayed in GoodCloud for the Site2Site connection.

Feuj

I have now tried it again with a B1300 - exactly the same effect.
B1300 as main node and AR300M as node1. As soon as the main node is logged on to a VPN server via WireGuard, there is no access to the network behind Node1.

Addendum: an s2s network can also not be connected to routers on which VPN (via WireGuard) is running at the time. After turning it off on each router, the routers are also detected.

Looks like you are using Site to Site and running a VPN client in one of the Site to Site node at the same time. This is not recommended, as it can make the network particularly complex.