VPN client failed to connect

I’m trying to get my GL.iNet 300M Mini Smart Router’s OpenVPN client to connect to my OpenVPN instance at home, but it won’t let me, stating:

OpenVPN 2.5.0 mipsel-openwrt-linux-gnu [SSL (OpenSSL)] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]

library versions: OpenSSL 1.1.1d 10 Sep 2019

NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Private Key Password:'. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.

Exiting due to fatal error

VPN client failed to connect. This may be because of wrong configuration, unsupported parameters or terminated by the server. Please choose another VPN profile or abort the connection. 

The profile file start with:

dev tun
remote-cert-tls server
key-direction 1
redirect-gateway def1
dhcp-option DNS
remote x.y.z 1194 udp

dev tun
remote-cert-tls server

remote x.y.z 1194 udp


The device’s firmware version is 3.201.

Can someone tell me how to fix this?

Do you use pivpn?

There is always a line missing


If you add this line to your ovpn, upload to the router and the router will ask for your private key passphrase. Then it will connect

Thanks, I’ll try.

BTW I’m using OpenVPN in a docker instance on a Debian machine, so no pivpn.