VPN client problem

I have an issue with the VPN client on GL.inet on many models (AR300, AR750).
My VPN provider give an public ip who is acces by internet directly. When connect it, the interface Luci is accessible and the samba share too.
Have you planning a correctif for that ?


Can you give more details including screenshot?

If it is private you can send us email support at gl-inet.com

For example, if my VPN provider gives me the address, when I type the url in my web browser, i get the administration interface. If I perform a scan on the address, I see the port 139 open which corresponds to a samba share.
Client use: Openvpn client
I try to make screenchot if you want.

Thanks :slight_smile:

I never met vpn provider providing a public IP address.

All the member of this list Membres de la Fédération des fournisseurs d'accès Internet associatifs (FFDN) | Fédération FDN who doing VPN.
They provide a public IP address.

I cannot use your products with them.


I tried mine and checked. The vpn interface should have a firewall and reject incoming connection.

Can you tell me the firmware version you tried? I can have a further check

Can you go to GL.iNet download center and download 3.105 for your model.

This should be fixed.

Thanks you, for the job, i will make some tests and i make a return.

Hi, it works on ar750s with the new firmware.

The port forwarding works too !

it’s great! :blush:

I believe this was pointed out ages ago but ignored.

EDIT: found it (2017!) - Firewall Rules