Vpn instruction not working (mullvad)

Hello. Can you please tell me what this browser error means? I tried to set up vpn, I have an account, but nothing worked according to this instruction Mullvad Guide - GL.iNet)) Please tell me how to do the same through the command line, it seems to me that the ff interface is very

heavy, so it freezes.

It would be better to manually upload the Mullvad Wireguard configs: Account | Mullvad

If you login through the GL.iNet panel, it will download all Mullvad configuration files. That’s quite resource intensive. Downloading the configs yourself & then uploading them in the GL.iNet panel will be faster & shouldn’t cause this problem.

Just download the configurations (multiple locations are possible, it’ll download in a .zip) and upload that .zip file in the panel, under “Configurations”.

1 Like

First you need to upgrade to 3.215 firmware as old firmware maybe slow.

The it should be fast. Just wait a while because it takes time.

Thank you for your reply. The example in my photo is just from the latest firmware.

@Blobbie01 Thank you for your reply. I drew attention to one more unpleasant moment in setting up the wireguard-client . After everything hung for me, I logged out and re-entered wireguard-client . I can’t reset the settings in order to do it manually as you recommended. There is no reset, this picture hangs all the time (photo below)

As for the settings in manual mode, I understood you correctly, do you recommend downloading the zip file with the settings and entering them in this form?

For azirevpn and mullvad you should wait the UI configure it.

It maybe slow and the browser may freeze a while but it should be able to finish.

Thanks for the answer . If everything worked, I would not write about this problem)) This functionality works very badly (my experience), so I think the best option would be to fill in the configuration file manually.

@alzhao Hello . You see how it does not work effectively, I did not get an answer to my question))

In the end, I figured it out myself, in fact, everything is not difficult.

For those who will read this topic and also look for answers, I will write a solution, since the MUDI interface works terribly, hangs and nothing works. Photo attached.

1.You need to go to mullvad official website.
2. Log into your account (this is the set of numbers that you received when you created your new account)
3. On the left you will see the inscription wireguard configuration
4. Next you need to configure your settings (generate key, select country, server, advanced settings etc) and click on download zip file.
5. Inside this file there will be configuration files. Open them with a text editor and add them to the configuration section in MUDI > wireguard Client > Configuration.

Next, give the name of this configuration and click connect!

Congratulations you did it :slight_smile:


1 Like

Thanks for the detailed guide.

Actually we have a online doc https://docs.gl-inet.com/en/3/tutorials/wireguard_client/#mullvad

May not as details as your post.

Configuring Mullvad using the UI takes 1minutes and 10 seconds in my side.

It takes time because it pulls 400+ config files.

Then the browser is slow because the UI deals with the 400+ files. As the UI runs on the browser so if you use a fast pc, the UI renders faster.

The whole process is optimized in firmware 4.x already.

1 Like

@alzhao Thanks for your answer and detailed explanation. I’m glad that my mini-instruction can help someone in the future. Not everyone has such powerful computers as you)) I have an old pc. And as you saw, an error constantly occurs, I sat for 20 minutes and waited for everything to be set up. In manual mode, as I described in the instructions, it took me 30 seconds, maybe less.

Moreover, when I left this section and re-entered the interface ( wireguard-client) did not reset and everything hung again. It seems to me that you need to make sure that after the user exits the wireguard-client section, the settings are reset or something like that …