Vpn Over LAN: GL-MT300N-V2

Hi,

I’ve bought a GL-MT300N-V2 in order to serve as a ‘VPN router’ for my PS4 to watch non local netflix.
I have a Nordvpn account.

I can setup the VPN ok, which - if I connect via Wifi - works.

However, no matter what I do, I cannot get the traffic via the Ethernet port to be running through the VPN.
I want it to be wired for bandwidth maximisation.

What am I doing wrong?

Thanks

what is your firmware version of GL-MT300N-V2?
It is weird, if the WiFi worked, connect via ethernet cable should be worked.
Please make sure the ethernet cable should connect to the LAN port.

By the way, to get a better VPN speed, WireGuard is much faster than OpenVPN, you can find a WireGuard provider below.
https://docs.gl-inet.com/en/3/app/wireguard/#wireguard-providers
Please make sure they can watch Netflix before you buy it.

Hi Leo,

So - to confirm;

I’ve already got a NordVPN account - it works fine over Wifi and I’ve been using it for years to watch Netflix. Won’t be able to pay for a second VPN until 2024!
Firmware version is (It updated straight away) 3.105
And yes, I’ve tried a PC and the PS4 attached to Ethernet with the Broadband router attached to WAN.

Wifi goes through VPN from the mango, ethernet is just straight passthrough.

I just try a GL-MT300N-V2 with 3.105 and running OpenVPN Client with NordVPN Hong Kong Server, it works both on Wi-Fi and ethernet cable.

Are you using the VPN Policy or other special feature?

How about try to Revert Firmware? (Admin Panel -> More Settings -> Revert Firmware)

Hi Leo,

VPN Policy - No.

Revert Firmware. I can do, but has to be said;

I bought it (about a week ago) - tried it out of the box, didn’t work.

Firmware upgraded - didn’t work.

So…not sure this will help, as far as I know we’re going back to what I tried before, but not sure what else to try.

Is there anyway of me posting screenshots so you can help me check the config?

PS I looked at that list of VPN providers. As luck would have it, I did buy a Keepsolid account some years back, so I could use that instead.

OK, rolled back. Same thing. Have upgraded again.

I’m going to try a reset and start from scratch.

You can upload screenshot, there is a button named ‘Upload’ above the input box.

So, did you try to revert the firmware?
NordVPN is OK, it should work. Nordvpn is the VPN providers I test most often.

Is the solution for this? I’m having the same problem with my Slade. Have wireguard set up and wifi works fine.

Cannot get the hardwire Ethernet to connect. It says it’s connected on my computer, but the internet doesn’t work.

Can you access the router’s UI on your computer?
Does the computer has some further settings, e.g. vpn, dns that cannot go through the wireguard?

I don’t understand why on wifi it works but not on lan. Did you test on different devices or just one one computer test on wifi or lan?

Just FYI to close this out, a full reinstall of firmware from scratch worked.

1 Like