VPN Policy Base on the Target Domain or IP issues

I have my Gl AXT1800 (Slate) configured with wireguard VPN (Mullvad) with the option “VPN Policy Base on the Target Domain or IP”. I have some domains on that with the option No use VPN, but it isn’t working with the domain address. Just when I enter the Ip address, the rule works. I am a new user, so I’m not sure if I forgot something. The problem for me in using the IP in this rule is that some sites change their address daily.

Let me know what files I have to share. Currently, I am using the last firmware 4.1.0 release 07.
OpenWrt 21.02-SNAPSHOT r16399+157-c67509efd7 /

It sounds like DNS is not parsed.
Do you enable “Block Non-VPN Traffic” options? What are your DNS settings?

1 Like

It is disabled. I’ve checked.

Just works if I input the IP address. I applied a config to adguard home to see all my clients there instead of the localhost. Maybe it is the responsible for the issue?

AdGuardHome on GL routers - Product Discussion - GL.iNet (gl-inet.com)

Yes, these configs causes all DNS requests to be resolved in ADGuard Home. As a result the VPN does not know exactly which domain your client is requesting.

Incidentally, in version 4.2, the firmware has been added to provide options and descriptions. Users can turn on ADGuard Home Handle Client Request, where ADGuard Home will show which client the request is coming from, but the domain based VPN policy will not work.

1 Like

Ok, understand,
Any chance in future updates that this function can work together with adguard home?
Thank you

By the way, my current firmware version is 4.1.0, and I don’t see any update available to 4.2, is that ok?

There is a 4.2.0 beta2 firmware download for the GL-AXT1800 that you can try, but it may still have some bugs.

I do not work for and I do not have formal association with GL.iNet

1 Like

We would also like them to work together, but so far we haven’t found a solution.

It has not yet been officially released, and only the Beta version has been released so far. It can only be installed manually.
If you are using AXT1800 in a live or production environment, please keep it in Release.

1 Like

Thank you for your support. Right now, I have reverted the config and also started to use NextDNS. I prefer it to Adguard,
Yes, I stay with the current firmware as I have just started learning about the Gl router and configs etc.