VPN server only passes traffic for first few client connections

Hello. I have been scratching my head over what is causing this. I have a VPN server on Brume 2. I manage to connect to it from OpenVpn (IOS) and everything works fine, however after a couple of times of connecting to it, VPN connects, but with no data passed through unless I reboot the router and refresh VPN configs. Appreciate any inputs.

Server side:

  • Device: Brume 2 (both 4.1 and 4.2 firmware tried, same result)
  • VPN type: Open VPN and Wireguard server (same behaviour in both cases). Additionally tried lower MTUs but no difference
  • VPN server port: Tried various ports no difference
  • DDNS: Active (ping always succeeds)
  • VPN cascade: To NordVPN (without cascade has the same behaviour)
  • Allow local network access: ON
  • Timezones: Correct and up to date
  • VPN policy: By MAC address (i.e. use NordVPN for the IOS device but not for others). Doesnt matter for VPN server anyhow
  • Network setup: Brume 2 → GPON router → Internet (GPON router is setup with DMZ for Brume 2 device with a static IP between Brume 2 and GPON router)

Client side:

  • Device: Iphone
  • VPN client: Open VPN and Wireguard apps, both gave same behaviour
  • Internet kill switch: On and Off tried, no difference

Observed behaviour:

  • On first activation of the VPN server, I am able to connect to it via the IOS device and both local and internet traffic are routed to the Brume 2
  • On disconnection of the client, and reconnection of the client sometimes it works 1-2 times, and sometimes work more times, but in the end within a few hours, on subsequent reconnections to the server the traffic goes to 0. I am not able to connect to see the Brume 2 gateway page, nor any internet traffic. I also tried pinging and that also doesn’t work.
  • Upon reboot, if I restart the server I again can connect 1-2 times but after that (or some time passing) my connection doesn’t allow any data to pass

I suspected that this may be due to public IP changes and the DDNS updates, but even when I connect directly with the public IP it doesnt work.

Any ideas would be much appreciated as I need a stable connection.

Does your public IP always change? Are you using domain names or fixed IP addresses in your exported client configuration?
You can compare the IP changes in normal and abnormal work