VPN: Temporarily solve same subnet conflicts

I am using my Gl.Inet router while I am traveling and I connect to my home with VPN. Sometimes I have problem, when remote subnet is the same as my home subnet (192.168.1.x). Sure, I should change this to something not commonly used range, but I have many devices on my network and I don’t have time to change.

On my PC I am using this temporary solution:

sudo route add -host 192.168.1.10 -interface ppp0

If I want to access home device at 192.168.1.10, it would be accessing trough ppp0 VPN interface.

It is possible to set static route like this on Glinet router?

You can add static routes on Luci.

Thank you, I tried to add here, but it’s not working. What I am doing wrong here?

192.168.9.4 is my Wireguard VPN interface IP address, I want to do a static route trough this interface.

Anyone? :slightly_smiling_face:

I added more info here:

Manually specifying ip route trough cli works:

ip route add 192.168.1.99 dev wg0

Any way to achieve this by GUI?

It would be also OK, if WG client/GUI interface would support PostUp/PostDown options:

PostUp = ip route add 192.168.1.99 dev wg0; ip route add 192.168.1.54 dev wg0; ip route add 192.168.1.155 dev wg0; ip route add 192.168.1.8 dev wg0;
PostDown = ip route del 192.168.1.99 dev wg0; ip route del 192.168.1.54 dev wg0; ip route del 192.168.1.155 dev wg0;