Vpn “VPN Policy Base on the Target Domain or IP” Invalid

I am using VPN, set to VPN Policy Based on the Target Domain or IP mode, the VPN will have no effect. If I change it to global mode, the VPN will take effect.

Make sure that the device, from where you are testing, uses the router as DNS server - this is important.

Can you describe in more details of how do you set up and how do you test.

I took a screenshot, you can take a look, thank you.

I added ipinfo.io to the domain list of the VPN, but after I turned on the VPN, there is still no VPN effect when testing ipinfo.io.

Below is a screenshot after I enabled global settings.

Yes, my computer’s DNS is my router.

This does not necessarily mean that it does not work. Complex “How is my IP” pages sometimes use techniques that are not intercepted by a single domain entry.

There is also caching. Both in the browser and in the router, which can also lead to false-negative results. Rebooting the router could solve this issue.

Please try the following domain: api.ipify.org

And then go to https://api.ipify.org

I understand what you mean, but it indeed does not take effect.
Screenshot 2024-02-02 at 9.02.36 AM
The ip of my vpn is

You’re sure that your browser does not use a different DNS server? Maybe some privacy extension?

Please check the current used DNS by visiting https://www.dnsleaktest.com/ - is it the right one?

Thank you very much, it seems to be caused by the adguard on my local device. I am continuing to troubleshoot, but there is still a problem on my phone. I will update later.

Apple Privacy Relay does the same thing. Maybe this causes the problem on phone.

Yeah, AdGuard on PC/Mac isn’t compatible if you don’t choose the router as main DNS.

Sorry, it’s still not working. I turned off AdGuard, but it still didn’t take effect. Only setting it globally will have an effect.

Please check all required settings. Your browser and device have to use the router as DNS.

AdGuard locally will change the way of how DNS requests are send. Try to uninstall it, for example. Make sure there is no other DNS server active.

Test with multiple devices. Make sure to enable, on the router, DNS > Overwrite DNS settings for all devices.

1 Like

Can you change the vpn policy to “Global” and change back to “Domain based”? This re-applies the policy in case some problems happens.