WAN freqent disconnects on Beryl AX

I recently bought a Beryl AX. Updated to latest stable firmware. Staying long-term at a hotel, and have ethernet, so seemed like the logical option. But when data is flowing (speedtest, streaming for 30-60 seconds, etc), the WAN drops frequently for what seems like an instant, maybe a second (not long enough for any of my devices to say no internet, but long enough for terrible buffering in streams, and if I’m watching the Beryl control panel, see a brief “no internet” message. Logs just report cable disconnected (no flow control issues or ping timeouts like I’ve seen in other threads). I turned the WAN off and tried wifi relay, and it works fine, no drops.

Based on a similar thread (Connection stability on GL-MT3000 - #8 by ck0), I tried updating to the 4.6 snapshot firmware, but it didn’t help at all (I’m still running it now). I also tried locking the port speed to 1Gbps (what the hotel link is negotiating), but I dont think its taking, or its not helping. Finally I just swapped the LAN and WAN ports using Luci, and that worked, and my connection is rock solid. But, the control panel doesn’t reflect the WAN status now, and one day in the future once I haven’t used it for awhile I’ll surely forget the ports are swapped!

No updates or comments on this? I have a colleague coming here and I want to recommend this router to him for the same usecase, but its hard because I don't know that they'll want to bother with all the steps required to swap the lan ports.