WAN port autonegotiation forcing 100Mb

AXT1800. The WAN port keeps autonegotiating 100Mb no matter what device or cable I connect it to. I can force 1000 via ethtool, but it never establishes the connection and goes back to 100Mb by itself shortly.

Any ideas? Is this [out of warranty] hardware just bad?

Are you able to swtich another port to WAN and test?

Using LuCI, I was able to swap eth0 and eth1 to be LAN and WAN.

Yes, now eth1 autonegotiates as 1Gb. So, the hardware is bad?

You said you tried different cables however swap the ports back and swap the known good cable thats on the Lan port over to your original wan and try again, just to rule that out.

I did test several cables and several devices. eth0 will only negotiate to 100Mb.

I know you did, but I was just asking to test the 100% known working cable by simply swapping them over and changing port back, if you did and it still doesn't work then fine, it was only a suggestion.

Just to add, you also didn't state what Firmware you are running. I would do a reflash of the current latest/stable firmware and toggle "keep settings" Off - could be a config issue

Hi alexr:

Can you configure WAN as LAN and check the negotiated speed?


As I noted above, I swapped eth0 and eth1 as WAN and LAN and eth1 works at the proper speed whereas eth0 does not.