WDS problem with AR750S connected to B1300

I am trying to use a 750S (firmware 3.009) in WDS mode to extend the range of my wifi network. The primary network router is a B1300 (firmware 3.022-0419). The connection appears to work for all of the devices connected to the 750S extended wifi signal. They can reach all other devices connected to either the primary or extended wifi networks.

The problem is that devices connected to the primary (B1300) using wifi can not connect to the devices on the extended (750S) portion of the network. Devices connected to the B1300 using the Ethernet ports have mixed results connecting to the extended devices.

I assume that I need to change some setting(s), but don’t know on which router or both.

Further info:

All local ip addresses on both primary & extended portions of the network are assigned and resolve correctly.

All devices connected to the B1300 (wifi or Ethernet) can connect with any other device connected directly to the B1300.

I can connect (ssh & https) to the 750S using the ip assigned by the B1300. This is surprising as I thought that “upstream” connections (on the 750S) were not allowed. The WDS connection page on the 750S also says “When you use Access Point/Extender/WDS mode, you may not connect to this UI again.”

There are 2 devices connected to the 750S extended network 1 on wifi (Ew1) and 1 using Ethernet (Ee2). There are 4 B1300 ethernet connected devices (Pe1, Pe2, Pe3, Pe4) all on same Ethernet port.
Pe1 can ping both Ew1 & Ee2.
Pe2 can ping Ee2 but Ew1 is “Unreachable”.
Pe3 can ping Ew1 but Ee2 is “Unreachable”.
Pe4 can ping Ee2 but Ew1 is “Unreachable”.

Generally, no wifi device connected to the B1300 can ping any of the devices connected to the 750S. Rarely, one device has been able to ping Ee2, but this is not reliable. Some B1300 connected devices can ping the 750S and some can’t.

AR750S uses the open wireless driver, while B1300 uses closed wireless driver.

Different driver has different implement of WDS, and they aren’t compatible with each other. You should use extender instead.

Thank you for the information on the WDS mode incompatibility between the B1300 and AR750S.

Is there any documentation available for the version 3 firmware that describes how to set up the two devices in extender mode? I can use either the gl.iNet Admin Panel or the Luci interface. Most of the links on the forum for this seem to onlt point to the basic documentation page.

For my application it is necessary for all devices to be on the same subnet and be able to access all other devices. The AR750S (entender) can use either a fixed or DHCP address (currently using DHCP).

Check the network mode in more settings

https://docs.gl-inet.com/en/3/setup/slate/more_settings/#network-mode

I put the AR750S into Extender mode and the AR750S connected devices were then on a 192.168.8.0 subnet and not on the main 192.168.1.0 subnet. For my application, I must have all devices connected to both the main (B1300) and bridge (AR750S) routers on the same subnet and able to communicate with all other devices.

My search of the forum indicates that this is possible using the “relayd” package if WDS does not work. However the links to the documentation for setting up relayd are not valid. Is relayd a solution that implements a bridge mode, and if so, where can I find information on how to implement it on the AR750S using version 3 firmware?

@mainer If you’re still getting 192.168. 8.x subnets then your unit isn’t set up properly for extender mode as it is still dishing out network addresses via DHCP . You need DHCP off so that your devices are given addresses from your “source” router (192.168.1.x)

AR750S extender mode is using relayd already.

Seems the set up is not successful. You can revert to router mode, turn off repeater manager and try again.

Repeater manager may change your settings while you are setting up extender

@limbot thank you for that suggestion, it has helped

@alzhao I assume that you want me to disable repeater manager by commenting out gl_health in /etc/rc.local ? that is the only reference I could find.

I am sorry for the length of this post but the situation is complicated and confusing and I am trying to give what information I have. I have a better understanding of the situation now. Unfortunately I still can not reliably get “Extender” mode to reliably work.
In the following:
B1300 is the main router at 192.168.1.1
AR750S-WDS is a client connected using WDS mode
AR750S-Ext is a client connected using Extender mode
AR750S refers to either/both clients above
I am using the 2.4G wifi to connect to unless indicated
I have 2 AR750S that I am testing with.

My setup process is:

  1. Reset AR750S to factory defaults (10 sec reset)
  2. Connect to AR750S
    set Admin password
    scan and connect (as Router) to wifi network
    at this point I have access to internet
  3. Change 2.4G and 5G ssid & key to my desired values
    re-connect to wifi as required by changes
    still on AR750S (192.168.8.0) subnet as Router
    at this point I have access to internet
  4. connect laptop to the B1300 (192.168.1.1)
    I can see the AR750S in clients
    I can ping (by name & ip)
  5. connect lan to AR750S wifi (192.168.8.1)
    go to advanced Network > LAN
    set DHCP Server to Ignore
    Save (but not apply)
    go to Admin Panel > Advanced > Network Mode
    set WDS on AR750S-WDS & connect to B1300
    set Extender on AR750S-Ext & connect to B1300

My results (as best I can determine):

on AR750S-Ext:
when connected to AR750S-Ext wifi:
can see internet & B1300
can see devices connected to AR750S-Ext
can see some devices connected to B1300 but not all
can not ping, ssh, or http to AR750S-Ext
when connected to B1300 wifi:
can see internet & B1300
can see devices connected to B1300
can see devices connected to AR750S-Ext
can not ping, ssh, or http to AR750S-Ext
this setup fails within minutes
I can no longer connect to AR750S-Ext or any device connected to it

on AR750S-WDS:
when connected to AR750S-WDS wifi:
can see internet & B1300
can see devices connected to B1300
can see devices connected to AR750S-WDS
can ping, ssh, and http to AR750S-WDS
when connected to B1300 wifi:
can see internet & B1300
can see devices connected to B1300
can see some devices connected to AR750S-WDS
from some devices connected to B1300 ethernet port
can see any “device” connected to AR750S-WDS
from any device that is bieng pinged from “device”
ping from AR750S-WDS “device” to B1300 device every 3 sec.
if pinging stops connection is lost within hour
can reconnect using AR750S-Ext wifi (above) and resume pinging
can not ping, ssh, or http to AR750S-WDS
this setup is stable from same location that AR750S-Ext fails

2.4G internet connection speed
of B1300 is 75 to 100 Mbps
of AR750S-Ext is 20 Mbps
of AR750S-WDS is 2 Mbps

The WDS solution I am using is OK at the moment, but I will be adding 2 additional devises that will be connected to the “Extender” router and that solution (and speed) will not be workable then. True “Extender” mode should work if it was stable and reliable. It would also greatly help if there was a way to connect to the Extender (like WDS) after that mode was set, but I have not been able to figure out how to do that.

Hi, I read your steps but I cannot follow the result part.

Seems you have done wrongly. So let me say gain this step.

  1. Make sure you are using latest firmware. You’d better try firmware v3.022 from here https://dl.gl-inet.com/firmware/ar750s/testing/, download the .tar file and upload.
  2. By turn off repeater manager, I mean this
  3. Set up AR750S as extender

You will be asked to scan network, choose your wifi and connect. You do NOT need to set up repeater in Internet page.

@alzhao Thank you for the reply. The “Repeater Options” that you show is not in the latest “release” version of the firmware. I downloaded the latest “testing” version and all of the results below are from the use of that firmware (ar750s-3.022-0329.tar).

Before each of the tests, I connected to the AR750S using ethernet and re-installed the ar750s-3.022-0329.tar firmware with “Keep Settings” OFF.

FAILED means that I loose the ability to connect to the AR750S using any of the 2.4G or 5G wifi or ethernet connections. With no ability to connect, and no ssh capability, the router is not usable.

In all of the test cases, I was connected by ethernet when I set the “Extender” mode, selected the wifi signal and key, and connected successfully. I then tested for internet access and was successful in every test. I would then attempt to switch to and test the 2.4G wifi access. Then do the same for the 5G wifi. The FAILED tests usually fail after 5 to 15 minutes of working correctly.

Test 1:
Installed & set admin passwords.
Set “Repeater Options”
Set up “Router” mode.
Set 2.4G & 5G wifi SSIDs & keys.
Set “Extender” mode & connected.
FAILED in 5 to 10 minutes.

Test 2:
Installed & set admin passwords.
Set “Repeater Options”
Set 2.4G & 5G wifi SSIDs & keys.
Set “Extender” mode & connected.
FAILED in 5 to 10 minutes.

Test 3 (minimal set up changes):
Installed & set admin passwords.
Set “Repeater Options”
Set “Extender” mode & connected.
Worked for longer tan 15 minutes using default wifi SSIDs & keys.
proceeded to Test 4.

Test 4:
Installed & set admin passwords.
Set “Repeater Options”
Set 2.4G & 5G wifi keys only.
Set “Extender” mode & connected.
FAILED in 5 to 10 minutes.

Test 5 (repeat of Test 3):
Installed & set admin passwords.
Set “Repeater Options”
Set “Extender” mode & connected.
Worked for longer tan 15 minutes using default wifi SSIDs & keys.
FAILED, I lost network access while editing this message.
Was connected to AR750S less than 45 minutes.

I would suggest that you have someone in you software validation group see if they can duplicate these tests. While all of the above tests were done on the same AR750S, I have had similar results with “Extender” mode on a different AR750S running the latest “release” firmware (openwrt-ar750s-3.009.tar).

Thanks for the detailed test. So in short it works for 5-10 seconds the break right.

I will test.

@alzhao
Two things to note:

  1. Fails usually occur after 5 to 10 minutes (not seconds) after applying Extender mode when changes are made to wifi settings.

  2. In both cases when I only changed Repeater Options, the failure did not occur within 5 to 10 minutes. In the first test (#3), I moved on to another test after 10 minutes. In the second test (#5) the failure occurred after about 45 minutes.

I am willing to run other tests if I can be of any help.

@alzhao
Has there been any progress on this issue?
Have you been able to duplicate my test results?

I am working on WDS from AR750s to S1300 (which should be very similar to B1300) and my connect is very stable so far.

Recently B1300 has a firmware upgrade. Can you pls try the new firmware?

@alzhao

My stability issues are when connecting the routers using “Extender” mode on the AR750S not when using WDS.

I have updated B1300 to version qsdk-b1300-3.022-0514.img and WDS to the AR750S is better with that version, but I still have problems when trying to connect from a device connected to THe B1300 to a device connected to the AR750S. The device connected to the AR750S can ping any device connected to the B1300 but not the other way. The WDS connection, DNS, and DHCP all work well and are very stable. The only problem is connecting from the B1300 attached devices to the AR750S attached devices.

I see that the S1300 has an 3.023-0523 update, is there another update coming for the B1300 that may help my WDS problem?

Actually I tried extender and WDS.

So the problem is accessing the device behind WDS/Extender from the main router, right? Will test this.

@alzhao
That is correct, everything else seems to work. The router to router connection is very stable in WDS mode.

With this diagram:

ClientA ---- B1300 —WDS—AR750S ---- ClientB
B1300 is connected to Internet

ClientB can connect/ping ClientA (or Internet)
ClientA can not connect/ping ClientB (see below for exception)
B1300 assigns ClientA and ClientB correct ip address.
B1300 correctly resolves ip for ClientB when name is is used by any device
Any device connected to AR750S can connect/ping any other device on network.

If ClientB pings ClientA every couple of minutes then ClientA can usually connect to ClientB. This is my current work around solution.

Hope this info helps.

@mainer I had tired WDS on AR750S to B1300, it indeed can work.

With this diagram:

ClientA ---- B1300 —WDS—AR750S ---- ClientB

It was working fine, would it caused by ClientA has enabled firewall?

With this diagram:
ClientA ---- B1300—WDS—AR750S ---- ClientB

  1. ClientA pings ClientB (ping fails with “Destination Host Unreachable”)
    then
  2. ClientB pings ClientA (ping succeeds)
    then
  3. ClientA pings ClientB (ping succeeds)

In the above sequence:
ClientA is either of two raspberry pi running raspbian (same result for both)

ClientB is any of (all identical results):
Dell laptop running Linux Mint
Samsung S10 phone running Android
raspberry pi running raspbian
Intel SBC running Linux Mint
ARM SBC running Linux Ubuntu

B1300 is running qsdk-b1300-3.024-0606
AR750S is running openwrt-ar750s-3.009
Steps 1 2 & 3 occur in succession with no changes to any settings between the steps.

Update:
I updated the AR750S to openwrt-ar750s-3.022-0329 with same results.
In step 1 (and 3) above ClientA receives the correct ip for ClientB.
I get the same results with no firewall on ClientA and/or ClientB.
After step 3 ClientA will loose the ability to ping ClientB after some time.